Hypnos

Hypnos est un logiciel client / serveur conçu pour Windows 2000 à Windows 10 pour les entreprises, collectivités et établissements scolaires permettant de :

  • Gérer l'organisation logicielle de votre parc (inventaire des logiciels installés, déploiement d'applications),
  • Optimiser le temps global de fonctionnement de vos ordinateurs (extinction intelligente des postes clients sans gêne pour les utilisateurs),
  • Optimiser la répartition des postes informatiques (calcul du temps d'utilisation des postes, du nombre de sessions ouvertes, génération de rapports détaillés).

Pour l'administrateur du réseau informatique, Hypnos Serveur montre en temps réel l'état de chacun de vos postes et d'effectuer en un clic des actions simples (réveil distant, extinction, fermeture de session, etc.).

Hypnos Serveur offre la possibilité de programmer des tâches d'actions de fichiers sur les postes clients (envoi / réception de fichiers, exécution de commandes, etc.), afin d'effectuer des installations logicielles semi-automatisées sur votre parc.

Pour la gestion, en assignant chaque poste client à un profil d'extinction personnalisable tenant compte de son temps resté inactif ou selon des critères horaires, vous réalisez des économies d'électricité significatives sur votre site et suivez en permanence leur évolution : vos postes laissés allumés ne fonctionnement donc plus inutilement ni en journée ni les soirs et week-end (gain de 50%).

Copie d'écran Hypnos Serveur

Pour le confort des utilisateurs de votre parc informatique, Hypnos Serveur peut aussi gérer l'éveil distant automatique de vos ordinateurs, et sait s'adapter aux horaires d'utilisation de chacun pour calculer intelligemment les heures auxquelles ils doivent être allumés automatiquement en dehors des périodes de vacances, afin que les utilisateurs aient leur ordinateur prêt à l'emploi à leur arrivée au bureau.

Pour les collectivités, un module complémentaire open-source Hypnos Manager est mis à disposition pour superviser depuis une interface Web plusieurs sites où est installé Hypnos Serveur.

Hypnos Serveur est téléchargeable en version shareware, et pleinement fonctionnel durant une période d'essai de 30 jours, à l'issue de laquelle vous devez obtenir une licence pour continuer à l'utiliser sans restriction (voir conditions de licence ).


Hypnos Serveur

Hypnos ››

Hypnos Serveur vous permet d'installer et configurer à distance le Hypnos sur les postes de votre réseau ou votre domaine.

Si nécessaire, configurez votre pare-feu afin de libérer le port de communication TCP 12768 de vos postes clients et serveur.

Paramétrez Hypnos Serveur en accédant aux différents onglets de l'application par un clic sur l'icône [image] située en zone de notification, près de l'horloge :

    1. Général : configuration des clients , des profils Hypnos , profils d'éveil , régimes de vacances ...

    2. Tâches : possibilité d'effectuer des actions de fichiers sur vos postes clients (par exemple : installations logicielles)

    3. Permissions d'éveil & d'arrêt : possibilité d'éveiller/arrêter des stations clientes depuis d'autres stations clientes

    4. Déploiement du client : installation et désinstallation à distance du client Hypnos

    5. Configuration : paramètres généraux d' Hypnos Serveur .

Ces options ne sont accessibles que si vous disposez des droits d'administration de l'ordinateur sur lequel est installé Hypnos Serveur .

Les droits d'administration du domaine sont néanmoins recommandés pour profiter pleinement de toutes les capacités du logiciel.


Général

Hypnos ›› Hypnos Serveur ››

A partir de l'arborescence située à gauche de la page Général, vous pouvez :

    1. Gérer vos clients , agir sur eux (éveil à distance, fermeture, redémarrage, ...) et générer des rapports d'activité

    2. Configurer des profils d' Hypnos (options d'arrêt, paramétrage du compte à rebours, ...)

    3. Paramétrer des profils d'éveil (horaires d'éveil, choix du régime de vacances associé, ...)

    4. Créer les régimes de vacances de votre site (paramétrage des différentes périodes de congés)

    5. Définir les semaines en alternance

    6. Basculer entre le mode normal et le mode maintenance

Sur la page de droite, consultez en temps réel les statistiques principales d' économies réalisées sur votre site :

Choisissez la période à analyser pour voir apparaître les informations correspondantes (semaine, 7 jours, mois, 30 jours, année, 12 mois, 5 années).

En vous positionnant sur la date du jour, la date sera automatiquement changée au fil des jours pour suivre l'évolution en temps réel de votre consommation.

Les données sont actualisées chaque jour à minuit.

Vous pouvez paramétrer la puissance moyenne de chaque ordinateur et le prix du kWh depuis la page Configuration .

Vous pouvez aussi exporter ces statistiques au format image (PNG) ou texte (CSV, TXT) depuis le menu contextuel.


Clients

Hypnos ›› Hypnos Serveur ›› Général ››

Gérez vos clients Hypnos depuis l'arborescence située à gauche.

  • Chaque nom de client est accolé à une icône indiquant son état :
    • : le client est allumé, et un utilisateur a ouvert une session (état appelé "Utilisé" dans les rapports d'activité ).
    • : le client est allumé, aucune session ouverte (état appelé "Hors session" dans les rapports d'activité ).
    • : le client est déconnecté. Si le poste est en marche, le client peut avoir été désinstallé, ou son pare-feu mal configuré.
    • : le client est inconnu : son nom a été déclaré, mais aucune information le concernant n'est recensée. Les informations le concernant seront recensées lors de sa première connexion.
    • : le client n'est pas géré du fait des restrictions de licence .

Le survol avec la souris d'une ligne où le client est connecté et avec une session ouverte indique le nom de l'utilisateur en cours.

Le nombre total de clients connectés au serveur est indiqué en permanence en haut de l'arborescence.

  • Par un clic droit sur un ou plusieurs clients, vous accédez aux options du menu contextuel .

  • Par un clic gauche, vous affichez les paramètres des clients dans la page de droite : informations , paramètres d'éveil , profils , données d'activité , logiciels installés , moniteurs .


Menu contextuel

Hypnos ›› Hypnos Serveur ›› Général ›› Clients ››

Vous accédez au menu contextuel par un clic droit sur un ou plusieurs clients (l'affichage dépend de la sélection) :

Menu contextuel client

Menu contextuel dossier

  • Ajoutez, Dupliquez ou Supprimez les clients que vous souhaitez.

Le fait de supprimer un client ne fait que supprimer les données en mémoire dans la base de données d' Hypnos Serveur : la désinstallation du client sur l'ordinateur distant doit être faite séparément, par exemple depuis l'onglet de déploiement .

Il n'est pas nécessaire que vous ayez déclaré un client pour que ce dernier s'inscrive dans l'arborescence : son inscription est automatique dès lors que l'option inscription automatisée des clients est activée.

  • Renommez un client pour indiquer son nom attendu alors qu'il ne s'est encore jamais connecté et que l'option inscription automatisée des clients est désactivée.

  • Rangez vos clients dans des dossiers pour améliorer l'organisation et la lecture de l'ensemble.

Le menu Arborescence des dossiers vous permet trois modes d'affichage :

- choisissez le Mode A et le Mode B pour afficher par exemple la répartition de vos clients par modèle de machine ou en fonction de leur localisation

- choisissez Ignorer pour lister vos clients de manière linéaire (ceci permet de sélectionner facilement l'ensemble de vos clients)

Exemple :

Mode A

Mode B

Mode Ignorer

L'option Créer un dossier par modèle client vous permet de créer autant de dossiers que de modèles différents de clients, et de les y regrouper. Ceci remplace les dossiers précédemment créés.

Si vous supprimez un dossier, il vous est demandé si vous souhaitez déplacer les clients contenus dans ce dernier à la racine de l'arborescence, ou si vous souhaitez les supprimer : dans ce dernier cas, leurs données sont supprimées mais ils sont pas désinstallés sur les postes correspondants.

En verrouillant un dossier [image] , les clients qu'ils contiennent seront ignorés lorsque vous enverrez une action d'arrêt, de redémarrage, etc. à ce dossier. Pour envoyer une action à ces clients, vous devrez alors les sélectionner spécifiquement. Vous pouvez à tout moment déverrouiller un dossier en cliquant sur l'icône [image] .

Vous pouvez utiliser les commandes Couper / Coller ou le glisser / déposer de la souris pour déplacer des clients d'un dossier à l'autre.

Note : Il n'est pas possible de créer de sous-dossiers.

  • Vous pouvez également trier vos clients selon plusieurs critères (nom, profil Hypnos , profil d'éveil , état, adresse MAC, modèle, système d'exploitation, numéro de série, adresse IP, dernière activité).

  • L'ajout de tous les ordinateurs du domaine permet de déclarer tous les ordinateurs adhérents à votre domaine de travail, sans avoir à les renseigner manuellement.

  • Lorsqu'un poste vient à être remplacé, vous perdez ses données de connexion si vous supprimez le client obsolète dans la console.

Pour ne pas perdre ces données :

    1. Installez le client sur le nouveau poste afin qu'il s'affiche dans la console.
    2. Sélectionnez ensuite le client du poste à remplacer puis, dans le menu Changement de poste, sélectionnez 1. Définir comme ancien client.
    3. Sélectionnez enfin le client correspondant au nouveau poste puis, dans le menu Changement de poste, sélectionnez 2. Définir comme nouveau client.

Les données de connexion de l'ancien client seront affectées au nouveau client, et l'ancien client sera automatiquement supprimé.

Note : Cette opération ne peut s'effectuer que si l'ancien client est déconnecté.

  • En exportant la sélection, vous créez en fichier au format CSV ou TXT comportant pour chaque client sélectionné différentes informations utiles (nom, adresse MAC, modèle, système d'exploitation, numéro de série, dernière IP, dernière activité, réseau utilisé, ancien nom connu du poste (si applicable), nom du dernier utilisateur, profil Hypnos, profil d'éveil...).

Exemple (détail) :

Client | Adresse MAC | Modèle | Numéro de série | Adresse IP | Dernière activité (Timestamp) | Dernière activité (Date) | Dernière activité (Heure) | Réseau
CDI-01 | 002324793F61 | LENOVO - 10AHS1RJ00 | S4F91446 | 172.16.104.1 | 1414320512 | 26/10/2014 | 11:48 | Local (LAN)
CDI-02 | 002324793F5E | LENOVO - 10AHS1RJ00 | S4F91440 | 172.16.104.2 | 1414320512 | 26/10/2014 | 11:48 | Local (LAN)
CDI-03 | 002324793F51 | LENOVO - 10AHS1RJ00 | S4F91458 | 172.16.104.3 | 1414320512 | 26/10/2014 | 11:48 | Local (LAN)
CDI-04 | 002324793F43 | LENOVO - 10AHS1RJ00 | S4F91442 | 172.16.104.4 | 1414320512 | 26/10/2014 | 11:48 | Local (LAN)
CDI-05 | 002324793F84 | LENOVO - 10AHS1RJ00 | S4F91453 | 172.16.104.5 | 1414320511 | 26/10/2014 | 11:48 | Local (LAN)
CDI-06 | 002324793F85 | LENOVO - 10AHS1RJ00 | S4F91450 | 172.16.104.6 | 1414320512 | 26/10/2014 | 11:48 | Local (LAN)

Note : L'affichage des adresses MAC peut-être modifié depuis l'onglet Informations .

  • La prise de contrôle à distance vous permet de prendre en main l'ordinateur sur lequel Hypnos est installé (clients LAN uniquement)

  • Vous pouvez Explorer le disque dur C: du client sélectionné (clients LAN uniquement)

  • Vous pouvez également forcer le rafraîchissement de l'état d'un ou plusieurs clients, si vous ne souhaitez pas attendre le rafraîchissement automatique (compter alors environ 4 - 5 secondes)

  • Les actions Réveiller, Fermer les sessions ouvertes, Redémarrer, Mettre en veille prolongée, Eteindre s'appliquent à tous les clients sélectionnés et à tous les clients des dossiers sélectionnés (exceptés les dossiers verrouillés).

Note : Il n'est possible de réveiller un client situé sur le réseau WAN que si un client relais présent sur le même réseau a été défini et est actif, ou si une Passerelle WOW est correctement paramétrée.


Informations

Hypnos ›› Hypnos Serveur ›› Général ›› Clients ››

En sélectionnant un clique, vous accédez aux informations recueillies :

  • Alias : indiquez un nom alternatif pour le client sélectionné, dans le cas où le nom réel ne permettrait pas suffisamment à identifier le poste
  • Adresse MAC : modifiez l'affichage de l'adresse MAC en page Configuration ,
  • Modèle : Le modèle indique le nom du fabricant et le modèle du poste client s'il existe,
  • Système d'exploitation : Cette information indique le nom complet du système d'exploitation du poste client, son numéro de version, et, s'il en est un, le service pack installé,
  • Numéro de série : numéro de série du BIOS (ou de la carte mère) si ce dernier est disponible,
  • Dernière IP,
  • Date de la dernière activité,
  • Réseau : LAN (réseau local) ou WAN (réseau étendu) si la dernière connexion utilisait une passerelle ou n'était pas connectée depuis une IP du réseau local ,
  • Ancien nom client : Indique le nom précédent utilisé par l'ordinateur, si celui-ci a été modifié depuis son premier recensement par Hypnos,
  • Utilisateur précédent : Donne le nom d'utilisateur de la dernière personne à avoir ouvert une session
  • Commentaire : Il s'agit d'un champ permettant d'ajouter un texte libre pour le(s) client(s) sélectionné(s).

Note importante : Hypnos Serveur est conçu de sorte que chaque client soit identifié d'abord par son adresse MAC si elle est connue, puis par son nom NETBIOS si l'adresse MAC n'a pas encore été recensée. Ainsi, si un poste client est renommé, la mise à jour du nom se fera automatiquement dans la liste des clients.


Paramètres d'éveil

Hypnos ›› Hypnos Serveur ›› Général ›› Clients ››

Sélectionnez un ou plusieurs clients pour préciser leurs paramètres d'éveil distant (Wake On Lan):

  • Renseignez le masque de sous-réseau depuis lequel les clients sont accessibles

Exemple 1 : Si la dernière IP recensée de votre client est 10.13.126.104 et que le masque de sous-réseau est 255.255.252.0, la trame d'éveil sera transmise en l'adresse de broadcast 10.13.127.255.

Exemple 2 : Si la dernière IP recensée de votre client est 172.16.130.16 et que le masque de sous-réseau est 255.255.0.0, la trame d'éveil sera transmise en l'adresse de broadcast 172.16.255.255.

  • Précisez le Port qui sera utilisé (0, 7, 8 ou 9)
  • Le masque de sous-réseau et le port par défaut sont déterminés dans l'onglet Configuration .
  • Si la carte réseau du client prend en charge l'option SecureOn pour protéger l'éveil distant Wake On Lan par un mot de passe, indiquez-le au format hexadécimal (exemple : FA 02 6C 6D 5E 93), ou bien laissez le champ à sa valeur par défaut (00 00 00 00 00 00) pour ignorer la prise en charge du mot de passe.
  • Si le client est sur le même vLan, il n'est pas nécessaire de définir de Relais.

Si le client est sur un vLan ne permettant pas de broadcaster les trames d'éveil, définissez un client Relais situé sur ce vLan. Ainsi, s'il est actif, il pourra transmettre les trames d'éveil aux clients ciblés.

Si le relais utilisé est Passerelle WOW, vous devez définir un serveur de votre choix (Nom d'hôte ou IP), acceptant de transmettre les trames d'éveil qu' Hypnos Serveur lui enverra via le port sélectionné pour réveiller le client.

La liste Utilisé comme relais par indique tous les clients pour lesquels le client sélectionné a été défini comme relais.


Profils

Hypnos ›› Hypnos Serveur ›› Général ›› Clients ››

Pour le(s) client(s) sélectionnés, choisissez :

1. le profil Hypnos qui sera utilisé pour définir les arrêts des postes

2. le profil d'éveil (facultatif) qui sera appliqué pour l'allumage automatique

3. le suivi continu (facultatif, pour les serveurs) :

    • Aucun : (par défaut) : pour les postes de travail classiques (ceux qui ne sont pas des serveurs)
    • Hypnos Manager 1 et / ou 2 : l'état du poste serveur (allumé / éteint) est transmis toutes les 10 minutes à Hypnos Manager , pour prévenir l'administrateur en cas d'interruption de service.


Données d'activité

Hypnos ›› Hypnos Serveur ›› Général ›› Clients ››

Créez des rapports d'activité pour les clients sélectionnés :

Ces rapports peuvent être au format CSV (format compatible avec Microsoft Excel et OpenOffice Calc) ou au format TXT (lisible par n'importe quel traitement de texte).

Les délimiteurs utilisés peuvent être paramétrés en page Configuration .

Sélectionnez le type de rapport à générer (chronologique ou global), la période couverte par le rapport désiré (incluant la date de Début et de Fin), puis cliquez sur le bouton Générer.

Voici un aperçu de chaque type de rapport :

  • Chronologique (un ligne par événement)

Timestamp | Client | Evénement | Utilisateur(s) | Jour de la semaine | Date | Heure | Durée | Durée (secondes)
1395299183 | PHYSIQUE10 | Hors session |  | Jeudi | 20/03/2014 | 08:06:23 | 00:14:29 | 869
1395300052 | PHYSIQUE10 | Utilisé | gautierc | Jeudi | 20/03/2014 | 08:20:52 | 09:39:15 | 34755
1395334807 | PHYSIQUE10 | Arrêté par Hypnos |  | Jeudi | 20/03/2014 | 18:00:07 | 19:16:44 | 69404
1395404211 | PHYSIQUE10 | Hors session |  | Vendredi | 21/03/2014 | 13:16:51 | 00:16:49 | 1009
1395405220 | PHYSIQUE10 | Utilisé | gautierc | Vendredi | 21/03/2014 | 13:33:40 | 02:56:39 | 10599
1395415819 | PHYSIQUE10 | Hors session |  | Vendredi | 21/03/2014 | 16:30:19 | 00:00:00 | 0
1395415819 | PHYSIQUE10 | Arrêté |  | Vendredi | 21/03/2014 | 16:30:19 | 07:29:41 | 26981

Nombre d'arrêts par Hypnos : 1

Temps économisé par Hypnos (secondes) : 69404 19:16:44 0,13 €

Puissance moyenne d'une station : 50 Watts

Prix du kWh : 0,14 €

Rapport d'activité Hypnos Serveur 3.1.0.6 du 19/03/2014 au 21/03/2014

Le Timestamp correspond au temps UNIX indiquant le nombre de secondes écoulées depuis le 1er janvier 1970 : le classement chronologique est ainsi facilité.

Note : L'indication de "Temps économisé par Hypnos " mentionnée en fin de rapport peut différer légèrement du cumul des durées en secondes lors des arrêts par Hypnos en raison :

        • du paramètre de plafond des économies
        • d'un éventuel reliquat d'économies courant entre 00:00:00 le premier jour du relevé et la première activité de la machine, si son dernier arrêt a été effectué par Hypnos

  • Global (une ligne par client résumant son activité sur la période choisie)

Client | Utilisé | Hors session | Temps total | Utilisé (secondes) | Hors session (secondes) | Temps total (secondes) | Economies | Economies (secondes) | Nombre d'arrêts par Hypnos | Nombre de sessions ouvertes | Economies (€) | Mode A | Mode B | Commentaire
HISTOIREGEO117 | 21:25:32 | 00:33:48 | 21:59:20 | 77132 | 2028 | 79160 | 01:24:46 | 5086 | 1 | 30 | 0,01 | Poste professeur |  |
HISTOIREGEO119 | 16:41:32 | 01:41:31 | 18:23:03 | 60092 | 6091 | 66183 | 01:11:47:15 | 128835 | 3 | 25 | 0,25 | Poste professeur |  |
MUSIQUE | 17:53:36 | 00:20:07 | 18:13:43 | 64416 | 1207 | 65623 | 00:00:00 | 0 | 0 | 22 | 0 | Poste professeur |  |
PHYSIQUE10 | 12:35:54 | 00:31:18 | 13:07:12 | 45354 | 1878 | 47232 | 19:16:44 | 69404 | 1 | 17 | 0,13 | Poste professeur |  | Labo Physique
Temps total | 02:20:36:34 | 03:06:44 | 02:23:43:18 | 246994 | 11204 | 258198 | 02:08:28:45 | 203325 | 5 | 94 | 0,39 |  |  |
Puissance moyenne d'une station : 50 Watts
Prix du kWh : 0,14 €
Rapport d'activité Hypnos Serveur 3.1.0.6 du 19/03/2014 au 21/03/2014

Les colonnes indiquant les durées en secondes sont données pour en faciliter le traitement statistique par le logiciel de votre choix.

Toutes ces données peuvent être exportées automatiquement avec Hypnos Manager sur un serveur de base de données pour y être exploitées.

Vous pouvez Effacer les données pour supprimer l'historique complet des données de connexion des clients sélectionnés.

Si vous utilisez Hypnos Manager , les données supprimées sur Hypnos Serveur ne seront pas supprimées sur Hypnos Manager .


Logiciels installés

Hypnos ›› Hypnos Serveur ›› Général ›› Clients ››

Les options présentées dans cette page sont accessibles uniquement si votre licence dispose de cette option.

Listez les logiciels installés sur les clients sélectionnés, ainsi que leur numéro de version et leur date d'installation :

Cette liste s'actualise automatiquement à la fréquence choisie lors de la connexion des clients.

Pour forcer l'actualisation des informations, cliquez sur Rafraîchir : si le client est connecté, il transmettra aussitôt les logiciels dont il dispose, autrement, ces informations seront recensées lors de sa prochaine connexion.

Vous pouvez Enregistrer cette liste au format CSV ou TXT, ou encore l'Effacer (ceci n'impacte pas les logiciels installés sur les clients).

Note : Au survol de la colonne Client avec la souris, une info-bulle indique la date du dernier recensement de la liste des logiciels. Cette donnée apparaît également dans la dernière colonne, lors de la génération de la liste au format CSV ou TXT.


Moniteurs

Hypnos ›› Hypnos Serveur ›› Général ›› Clients ››

Les options présentées dans cette page sont accessibles uniquement si votre licence dispose de cette option.

Listez le ou les moniteurs raccordés aux clients sélectionnés, afin de visualiser leur :

  • Modèle
  • Numéro de série
  • Taille (en pouces)
  • Fabricant
  • Date de fabrication

Cette liste s'actualise à chaque connexion des clients.

Vous pouvez Enregistrer cette liste au format CSV ou TXT.

Note : Au survol de la colonne Client avec la souris, une info-bulle indique la date du dernier recensement de la liste des moniteurs. Cette donnée apparaît également dans la dernière colonne, lors de la génération de la liste au format CSV ou TXT.


Profils Hypnos

Hypnos ›› Hypnos Serveur ›› Général ››

Créez autant de Profils d'Hypnos que de configurations nécessaires souhaitées.

  • Faites un clic droit sur l'arborescence de gauche pour accéder au menu contextuel :

Vous pouvez :

    • Créer un profil Hypnos pour gérer un groupe de machines ayant un usage similaire
    • Renommer / Dupliquer le profil sélectionné
    • Supprimer le profil sélectionné. Le profil Par défaut ne peut être supprimé.
    • Définir un profil comme profil Hypnos par défaut qui sera utilisé par les nouveaux clients
    • Importer : afin de remplacer le profil courant par un profil d'origine
    • Importer / Exporter les données du régime sélectionné. Ceci permet aux administrateurs de plusieurs sites d'éviter de saisir plusieurs fois les mêmes données.

  • Cliquez sur un profil Hypnos , et paramétrez-le comme s'il s'agissait de configurer un client Hypnos :

    • Options d'arrêt (délai avant arrêt, fermeture, ...)

    • Ecran de veille et Alimentation

    • Icône en zone de notification

    • Compte à rebours

Une fois enregistrées, les modifications sont aussitôt transmises aux clients connectés correspondants au profil Hypnos sélectionné.

Les autres clients se mettront à jour dès leur prochaine connexion.


Profils d'éveil

Hypnos ›› Hypnos Serveur ›› Général ››

Créez autant de Profils d'éveil que nécessaire, et paramétrez-les pour personnaliser l'éveil via le réseau de vos postes clients :

  • Les profils d'éveils fonctionnent en deux modes distincts : le mode normal [image] (les horaires sont fixes, gérés par l'administrateur) et le mode intelligent [image] (les horaires sont calculés dynamiquement par Hypnos Serveur ).

  • Cliquez sur un profil d'éveil, et paramétrez-le :

Affichage mode normal

Affichage mode intelligent

    • Si le profil est en mode normal (horaires fixes) paramétrez les différents horaires d'éveil de la semaine, qui s'appliqueront aux clients associés au profil :
      • Etat :
        • Actif : le signal d'éveil sera envoyé
        • Inactif : le signal d'éveil ne sera pas envoyé
      • Semaines : détermine si l'éveil doit se faire toutes les semaines, ou une sur deux selon votre calendrier des semaines en alternance .
      • Jours & Heures : pour indiquer le moment de la semaine où la trame d'éveil doit être envoyée à vos postes clients.

    • Basculez du mode normal au mode intelligent en changeant l'attribution du mode d'éveil.

Lorsqu'un profil est en mode intelligent , vous pouvez exécuter un calcul des horaires en cliquant sur l'icône [image] . Cette opération s'effectue automatiquement chaque jour à minuit.

    • Sélectionnez le régime de vacances associé au profil d'éveil.

Indiquez Aucun pour que le profil d'éveil soit appliqué sans tenir compte des périodes de congés : les horaires choisis seront alors appliqués toutes les semaines.

  • Faites un clic droit sur l'arborescence de gauche pour accéder au menu contextuel :

La réinitialisation des horaires intelligents consiste à supprimer la programmation en cours des profils intelligents.

Cette programmation se recalculera automatiquement dès minuit, ou bien manuellement en cliquant sur Recalculer les horaires intelligents.

Cette opération peut être utile lorsqu'on souhaite repartir sur une plage de programmation vierge, par exemple en début d'année.

Notes :

  1. En sélectionnant plusieurs profils d'éveil vous pouvez modifier leur régime de vacances et leur mode d'éveil en un seul clic.
  2. L'éveil à distance d'un poste client ne peut se fait qu'à condition que :
    • le BIOS et la carte réseau du poste soient compatibles et correctement configurés,
    • le poste client soit membre du même réseau local (LAN) que Hypnos Serveur ,
    • le port d'éveil et le sous-réseau du client soient bien renseignés,
    • l' adresse MAC de votre client soit connue d' Hypnos Serveur (cette donnée est recensée lors de la toute première connexion du client Hypnos).


Régimes de vacances

Hypnos ›› Hypnos Serveur ›› Général ››

Créez un ou plusieurs Régimes de vacances, qui seront utilisés par vos profils d'éveil pour ne pas effectuer d'éveil à distance sur les ordinateurs correspondants durant les périodes définies.

  • Une fois sélectionné un régime de vacances, faites un clic droit sur l'arborescence de gauche pour accéder au menu :

  • Le menu contextuel vous permet également d'exporter / importer les données du régime sélectionné :

En utilisant le menu Importer / Vacances scolaires zone A, B, C ou Corse, vous remplacerez les données du régime sélectionné par celles connues par votre version d' Hypnos Serveur .

Vous pouvez également choisir d'Importer / Exporter le régime depuis et vers un fichier : ceci permet aux administrateurs de plusieurs sites d'éviter de saisir plusieurs fois les mêmes données personnalisées.

De plus, vous pouvez verrouiller le régime sélectionné sur une zone de vacances (A, B, C ou Corse) afin d'utiliser automatiquement à chaque mise à jour d' Hypnos Serveur les données actualisées des périodes de vacances sans avoir à les ressaisir.

  • Cliquez sur un régime de vacances, et paramétrez-le :

En définissant le régime de vacances comme régime par défaut, les futurs profils d'éveils que vous créerez seront directement liés à ce régime de vacances.

Du premier au dernier jour de chaque période de vacances, aucun éveil à distance ne sera effectué sur les postes clients associés aux profils d'éveil attachés à ce régime de vacances.


Semaines en alternance

Hypnos ›› Hypnos Serveur ›› Général ››

Selon l'organisation de votre site, vous pouvez être amené à définir les Semaines en alternance qui pourront être utilisées dans la programmation de vos profils d'éveil .

  • Choisissez une désignation parmi les deux proposées (Semaines impaires & paires ou Semaines A & B).
  • Sélectionnez une année à paramétrer.
  • Cochez les boutons correspondant à l'organisation de votre calendrier.


Modes de fonctionnement

Hypnos ›› Hypnos Serveur ›› Général ››

Au bas de l'arborescence des clients, vous pouvez basculer entre le mode normal et le mode maintenance, en cliquant sur le bouton.

Choisissez ensuite le mode de fonctionnement qui vous convient, et cliquez sur Appliquer :

En mode normal, Hypnos applique aux clients les profils d'extinction tels que vous les avez paramétrés.

En mode maintenance, Hypnos suspend ses arrêts sur tous les clients pour une durée réglable (4 heures, 12 heures, 24 heures, 5 jours ou indéterminée).

Note : Les éveils automatiques ne sont pas suspendus lorsque le mode maintenance est activé.

Ces mêmes réglages peuvent être effectués directement depuis un clic droit sur l'icône en zone de notification près de l'horloge :


Tâches

Hypnos ›› Hypnos Serveur ››

Les options présentées dans cette page sont accessibles uniquement si votre licence dispose de cette option.

La page Tâches vous permet de créer des tâches de transfert de fichiers et d'exécution de commandes sur vos clients, et de planifier l'exécution de ces tâches.

Pour chaque tâche, vous définissez une succession d'actions, lesquelles peuvent être de types différents :

  • Envoi de fichiers / dossiers du serveur vers les postes clients.
  • Exécution de commandes sur les postes clients.
  • Réception de fichiers / dossiers des postes clients vers le serveur.
  • Envoi de messages d'information aux utilisateurs des postes clients.
  • Compression de fichiers
  • Décompression de fichiers

Les paramètres globaux du fonctionnement de cette page sont accessibles depuis l'onglet Configuration .

Par exemple, une tâche peut vous permettre d'installer / désinstaller un logiciel, de transférer des fichiers, d'exécuter des commandes MS-DOS, PowerShell, Wake-On-Lan, etc..

En haut de la page se trouve le tableau récapitulatif des tâches, en dessous duquel vous accédez au paramétrage de la tâche sélectionnée.

Exemple de capture d'écran du tableau récapitulatif des tâches

Les limitations de fonctionnement simultané sont les suivantes :

- nombre maximal de clients autorisés (toutes tâches actives confondues) : 100

- nombre maximal de clients ayant une tâche de transfert active (envoi / réception) : 10

- nombre maximal de transferts par client (envoi / réception) : 1

Les autres clients sont placés en file d'attente.

Lorsqu'un client a terminé la tâche, le client en attente le plus adapté est sélectionné par Hypnos Serveur .


Tableau récapitulatif

Hypnos ›› Hypnos Serveur ›› Tâches ››

Les options présentées dans cette page sont accessibles uniquement si votre licence dispose de cette option.

Lorsqu'aucune tâche n'est définie, cliquez sur le bouton Créer une tâche, ou sur Importer pour récupérer un fichier de tâches précédemment créés.

Lorsque vous avez créé une ou plusieurs tâches, vous accédez au tableau récapitulatif, dont voici un exemple :

Pour chaque tâche, le tableau récapitulatif livre 5 informations :

  • Le nom que vous avez défini.
  • Sa date de dernière exécution : cette information dépend des données présentes dans son historique. En effaçant l'historique d'une tâche, la date de dernière exécution bascule sur Jamais.
  • Le dernier état connu des cibles pour la dernière exécution de la tâche. Cette information s'affiche au format :

Nombre de clients cibles / Nombre de clients en succès / Nombre de clients en erreur

  • Sa date de prochaine exécution : elle peut être Manuelle, ou définie dans les options de programmation automatique de la tâche.
  • Son état : prête, interrompue ou en cours.

Le menu contextuel vous permet d'accéder aux opérations principales des tâches sélectionnées :

Vous pouvez ainsi :

  • Créer une tâche, la renommer, la dupliquer ou la supprimer.
  • Importer / Exporter une ou plusieurs tâches : si vous administrez plusieurs serveurs Hypnos Serveur ces opérations vous éviteront de redéfinir manuellement chacune d'elles.

Important : Si vous avez défini un code d'accès dans l'onglet Configuration , les fichiers créés lors de l'export contiennent les détails des tâches sous forme non cryptée.

  • Exécuter / Interrompre les tâches sélectionnées. L'interruption d'une commande en cours d'exécution termine tous les processus enfants qui en dépendent.
  • Effacer l'historique des tâches sélectionnées : cette opération supprime les détails de journalisation collectés pour toutes les fois où chaque tâche a été exécutée.


Paramétrage

Hypnos ›› Hypnos Serveur ›› Tâches ››

Les options présentées dans cette page sont accessibles uniquement si votre licence dispose de cette option.

Lorsque vous avez créé une tâche , défini son nom, et qu'elle est seule sélectionnée dans le tableau récapitulatif vous pouvez la paramétrer.

Pour paramétrer une tâche :

  • Sélectionnez les cibles :

Les cibles peuvent être des clients comme des dossiers de clients.

Les dossiers clients sont ceux définis dans la page Général , et dépendent du mode d'arborescence choisi (A, B ou Ignorer).

En sélectionnant un dossier, tous les clients contenus dans le dossier seront ciblés au moment où la tâche sera exécutée.

Ainsi, en raison des déplacements de clients d'un dossier à l'autre que vous pourriez effectuer sur les arborescences, le fait de sélectionner un dossier n'est pas équivalent à sélectionner tous les clients de ce dossier.

Par un clic droit sur une cible, le menu contextuel vous propose les options simplifiées que vous retrouvez dans le menu contextuel de la page Général :

  • Actions :

Accédez au classeur de droite, page Actions.

Pour créer une action, cliquez sur le bouton Créer une action, ou utilisez le menu contextuel dans le tableau des actions.

Chaque action est accompagnée de son indicateur d'état qui sera appliqué au prochain lancement de la tâche :

    • Active : l'action sera exécutée
    • Inactive : l'action sera ignorée

Cliquez sur l'indicateur pour le faire changer d'état.

Il existe plusieurs types d'actions :

    • Envoi de fichiers :

Cette action consiste à transférer un ou plusieurs fichiers, depuis le serveur, vers les clients cibles.

Indiquez le nom du fichier ou du dossier source : la source doit être accessible au compte Système Local sur lequel tourne le service d' Hypnos Serveur .

Indiquez le nom du fichier ou du dossier destination : la destination doit être accessible au compte Système Local sur lequel tourne le service de client Hypnos .

Le chemin indiqué en source comme en destination peut comporter le caractère * pour désigner le nom du poste client cible.

Exemples si le poste cible s'appelle INFIRMERIE :

      • Si la source est S:\Fichier.txt et la destination C:\*\Fichier.txt, le fichier créé chez le client sera C:\INFIRMERIE\Fichier.txt.
      • Si la source est S:\Fichier_*.txt et la destination C:\Fichier.txt, le fichier source du serveur sera S:\Fichier_INFIRMERIE.txt et sera copié vers C:\Fichier.txt du le poste cible.
      • Si la source est S:\Fichier_*.txt et la destination C:\*\Fichier.txt, le fichier source du serveur sera S:\Fichier_INFIRMERIE.txt et sera copié vers C:\INFIRMERIE\Fichier.txt.

Notes :

      • Un nom de dossier doit se terminer par \ afin de ne pas être interprété comme un nom de fichier.
      • Il est possible d'envoyer un fichier dans un dossier

Exemple :

Si la source est S:\Fichier.txt et la destination C:\ le fichier destination sera C:\Fichier.txt.

      • Lors d'une copie de dossier, celui-ci est copié comme sous-dossier du dossier destination.

Exemple :

Si la source est S:\Dossier\ et la destination C:\, les données seront copiées dans C:\Dossier\.

En cochant la case Copier les droits NTFS, Hypnos copiera les droits de sécurité présents sur chaque fichier et dossier créé.

Dans tous les cas, l'horodatage des fichiers et dossiers sera conservé, ainsi que leurs attributs (lecture seule, fichier caché, etc.).

Remarque : L'exécution simultanée de plusieurs tâches d'envoi de fichiers avec le même client n'est pas permise.

    • Exécution de commande :

Indiquez une ligne de commandes à exécuter et, éventuellement, un répertoire d'exécution si cette commande doit se référer à d'autres fichiers.

Vous pouvez indiquer une ligne de commandes MS-DOS, comme un exécutable, une commande PowerShell, etc. : la ligne de commandes fonctionne comme le menu Windows Démarrer > Exécuter.

Des commandes spéciales sont également disponibles, telles que : réveiller, fermer les sessions ouvertes, redémarrer, mettre en veille prolongée, éteindre.

Les commandes MS-DOS sont exécutées dans l'environnement du compte Système Local du client.

Exemple : Pour supprimer le fichier C:\Fichier.txt, indiquez simplement comme commande : DEL C:\Fichier.txt.

Exemple de capture d'écran pour une tâche de déploiement d'application

dont les sources sont présentes sur un partage réseau

En cochant Attendre la fin de l'exécution de la commande, Hypnos attendra que la commande exécutée se termine avant de passer à l'action suivante.

Si votre commande renvoie des valeurs entières positives comme codes de sortie, vous pouvez les indiquer afin qu' Hypnos détermine si l'action a réussi ou échoué.

La syntaxe d'un code de sortie est :

[!]code_1[-code_2][,code_3[-code_4]...]

Remarque : Une infobulle donne des exemples de syntaxe au survol du composant avec la souris.

Exemples :

      • 12,15-18,30-60 : les codes de retours indiquant la réussite de la commande sont le 12, les entiers de 15 à 18 et ceux de 30 à 60.

Les autres codes signifient que la commande a échoué.

      • !3-5,11 : les codes de retours 3, 4, 5 et 11 indiquent que la commande a échoué.

Les autres codes signifient que la commande a réussi.

En cas de doute sur la chaîne que vous saisissez, celle-ci est optimisée par lors de l'enregistrement de la tâche.

    • Réception de fichiers :

Cette action est équivalente à celle de l'envoi de fichiers, sauf qu'elle prend comme source les fichiers des clients cibles, et les copie en destination sur le serveur.

Remarques :

      • L'exécution simultanée de plusieurs tâches de réception de fichiers avec le même client n'est pas permise.
      • Si la tâche s'applique à plusieurs clients cibles, l'utilisation du caractère * dans la destination est recommandée (ce caractère est remplacé par le nom du poste client) afin d'organiser la réception des fichiers, et qu'il n'y ait pas de conflit d'écriture au moment de la réception.

    • Envoi de message :

Cette action envoie un message à chaque utilisateur ayant ouvert une session sur les clients cibles.

Exemple de message d'avertissement

Le message se retire automatiquement au terme de la durée maximale d'affichage choisi si l'utilisateur n'a pas refermé la fenêtre.

En cas de message vide, l'exécution de la tâche patientera durant le temps indiqué, sans afficher de message, avant de passer à l'action suivante.

Le style du message détermine le son système utilisé pour signaler l'apparition du message, ainsi que l'icône affichée en regard de celui-ci :

      • Neutre : pas d'icône
      • Information :
      • Avertissement :
      • Confirmation :

Pour un message de confirmation :

La fenêtre utilisateur comporte deux boutons : OK et Annuler.

Si l'utilisateur clique sur Annuler ou sur le bouton de fermeture, la tâche est annulée.

Si l'utilisateur clique sur OK, ou, en l'absence de réponse au terme du délai imparti, la tâche passe à l'action suivante.

Pour les autres messages :

Un seul bouton est visible : OK.

La tâche passe à l'action suivante lorsque l'utilisateur ferme la fenêtre, sinon au terme du délai spécifié.

    • Compression :

Cette action vous permet de faire compresser par les clients cibles, un fichier ou un dossier au format ZIP.

Tout comme pour les transferts de fichiers, vous pouvez utiliser le caractère dans la source et plus spécialement dans la destination * pour qu'il soit remplacé à l'exécution par le nom du poste client.

    • Décompression :

Cette action vous permet de faire décompresser par les clients cibles, un fichier ZIP vers un dossier.

Là encore, le caractère *, s'il est utilisé, est remplacé à l'exécution par le nom du poste client.

L'option Passer à l'action suivante même si l'action a échoué précise la façon dont Hypnos doit se comporter en cas d'erreur : soit la tâche est interrompue pour le client cible, soit l'action suivante est entreprise.

Une tâche est considérée comme réussie sur un client cible si elle n'a pas été interrompue.

Le menu contextuel du tableau des actions propose de :

    • créer, dupliquer ou supprimer une action.

    • activer ou désactiver les actions sélectionnées

    • modifier l'ordre d'exécution des actions sélectionnées (également accessible depuis la combinaison CTRL+Haut et CTRL+Bas).

  • Planification :

Vous pouvez planifier le lancement de la tâche, et programmer son exécution répétée, selon cinq modes proposés :

    • Aucune : la tâche s'exécutera uniquement de façon manuelle, en cliquant sur le bouton Exécuter.
    • Tous les jours : indiquez la régularité (chaque jour, un jour sur deux, un jour sur trois, etc.), puis définissez l'heure et la date du premier démarrage. Précisez éventuellement la date de fin au-delà de laquelle la tâche ne doit plus être exécutée automatiquement.
    • Toutes les semaines : indiquez la régularité (toutes les semaines, une semaine sur deux, etc.), choisissez le(s) jour(s) de la semaine où la tâche devra s'exécuter, puis paramétrez l'heure et les dates de début et fin de validité de cette programmation.
    • Tous les mois : choisissez le mode numéral (exemple : démarrage les 13 et 25 de chaque mois) ou ordinal (exemple : démarrage les premiers et derniers lundis et jeudis de chaque mois), puis paramétrez l'heure et les dates de début et fin de validité de cette programmation.

Remarque : En cas d'utilisation de la planification des tâches, il peut être judicieux d'avoir activé l'option d' éveil automatique des clients cibles.

  • Historique :

A chaque lancement de la tâche, une entrée est créée dans l'historique de cette tâche.

En sélectionnant le moment (date & heure) de lancement de la tâche, vous accédez à un tableau à trois colonnes : Heure, nom du client cible et événement.

Vous pouvez Enregistrer ces informations au format CSV ou TXT.

Le survol avec la souris de la colonne événement peut vous donner des compléments d'informations sur les codes d'erreurs.

En cliquant sur Effacer, vous supprimez tous les événements du moment sélectionné.

En maintenant la touche CTRL enfoncée au moment du clic sur Effacer, vous supprimez la totalité des événements de l'historique en mémoire pour la tâche sélectionnée (cette même opération peut directement s'effectuer depuis le menu contextuel du tableau récapitulatif des tâches ).

Une fois la tâche paramétrée, cliquez sur Enregistrer pour valider les réglages.

Une tâche en cours d'exécution peut être modifiée, mais ne peut pas être enregistrée tant qu'elle n'est pas terminée.

Pour revenir aux derniers paramètres enregistrés, cliquez sur Restaurer.

Lorsqu'une tâche est prête à être exécutée vous pouvez la démarrer manuellement en cliquant sur Exécuter : vous pourrez alors Interrompre la tâche à tout moment jusqu'à la fin de son exécution.

Pour pouvoir être exécutée, une tâche doit comporter au moins un client cible et au moins une action valide.

Note : Les postes clients en cours d'exécution de tâche ne sont pas éteints par les procédures automatiques d' Hypnos .


Permissions d'éveil et d'arrêt

Hypnos ›› Hypnos Serveur ››

Depuis la page Permissions, créez des autorisations permettant à vos utilisateurs d'éveiller et arrêter manuellement une ou plusieurs stations clientes Hypnos .

Ainsi, depuis un ordinateur géré par Hypnos Serveur , les utilisateurs pourront agir sur d'autres ordinateurs.

A. Création de la permission :

    1. Dans Choix d'une permission, sélectionnez Nouvelle permission.

    2. Donnez un nom à la permission, par exemple le nom de la salle ciblée pour l'arrêt ou l'éveil des machines.

    3. Sélectionnez dans le cadre de gauche les stations autorisées à éveiller / arrêter les machines cibles présentes dans le cadre de droite.

Note : Si vous sélectionnez Toutes les stations, n'importe quelle machine sera autorisée à allumer / éteindre les machines cibles.

    4. Sélectionnez les stations cibles dans le cadre de droite.

    5. Cliquez ensuite sur Enregistrer pour sauvegarder les paramètres des permissions.

B. Création du script de permission :

    1. Sélectionnez une permission.

    2. Choisissez le type de script : Eveil ou arrêt des stations cibles.

    3. Éventuellement, cochez la case Message de confirmation si vous souhaitez que l'utilisateur du script soit averti d'un message confirmant le bon déroulement du script ou qu'une problème a eu lieu lors du traitement.

    4. Cliquez sur Générer et déposez le fichier dans un répertoire accessible aux stations autorisées à exécuter le script.

Notes :

- Si vous modifiez une permission, il n'est pas nécessaire de recréer les scripts qui en dépendent.

- Si vous supprimez une permission, les scripts qui en dépendent sont rendus inopérants.

- Un script ne peut être lancé que depuis les stations autorisées, et par les utilisateurs ne faisant pas partie d'un groupe de restriction sur ces machines.

- Pour que le script puisse être interprété, il est indispensable que la station hôte Hypnos soit connectée au serveur pour que ce dernier traite la commande.


Déploiement du client

Hypnos ›› Hypnos Serveur ››

Depuis la page Déploiement du client, installez ou désinstallez le client Hypnos sur les ordinateurs de votre réseau local.

Note : Il n'est pas nécessaire de déployer un client sur un ordinateur où il est déjà installé lors d'une mise à jour du serveur : la mise à jour des clients s'effectue automatiquement.

  1. Assurez-vous que les ordinateurs sur lesquels vous souhaitez installer ou désinstaller le client Hypnos sont allumés. Vous pouvez tenter un réveil global de votre parc en fournissant un fichier contenant des adresses MAC des machines à réveiller, ou interroger la table ARP de votre ordinateur.

Note : Si vous fournissez un fichier, ce fichier doit être un fichier texte. Quel que soit son format, les adresses MAC seront automatiquement reconnues à l'intérieur de ce fichier.

  2. Lancez une Recherche pour scanner brièvement votre réseau à la recherche des ordinateurs allumés.

Note : La liste affichée récapitule l'ensemble des unités ayant répondu à un ping du serveur dans un délai raisonnable. Il est donc possible que certaines ne correspondent pas à des stations mais à des routeurs, switches ou imprimantes par exemple. L'installation ou la désinstallation du client vers ces unités sera sans effet.

  3. Sélectionnez dans la liste proposée le ou les ordinateurs vers lesquels installer ou désinstaller le client Hypnos .

Les stations pré-cochées indiquent celles sur lesquelles le client Hypnos n'est apparemment pas installé.

Utilisez la combinaison CTRL + A pour cocher / décocher la liste complète.

Si vous souhaitez effectuer un déploiement sur un poste allumé qui n'est pas listé, vous pouvez effectuer un Ajout manuel en saisissant son nom ou son IP.

  4. Choisissez vos identifiants : soit les identifiants de votre session courante, soit les identifiants de votre choix.

L'identité choisie doit disposer des droits d'administration sur tous les postes sélectionnés.

En choisissant l'identifiant de votre choix, vous pouvez indiquer la variable %COMPUTERNAME% dans le nom d'utilisateur pour préciser un compte local sur la machine destination.

Exemple : %COMPUTERNAME%\administrateur

  5. Cliquez sur Installer ou Désinstaller.

  6. L'état d'avancement de l'installation / désinstallation s'affiche dans un tableau récapitulatif.

Note : La désinstallation du client sur un poste ne retirera pas son entrée dans la console des clients .


Configuration

Hypnos ›› Hypnos Serveur ››

Paramétrez dans la page Configuration, les options générales de l'application d' Hypnos Serveur :

  • Clients

Mot de passe :

Définissez un mot de passe afin de protéger, sur les clients, l'accès aux paramétrage d' Hypnos par les utilisateurs.

Ce mot de passe est aussitôt appliqué à tous les clients connectés. Les autres clients se mettront à jour dès leur prochaine connexion.

Seuls les administrateurs des postes clients peuvent accéder au paramétrage d' Hypnos , dans la mesure où ils ne figurent pas dans les groupes non autorisés renseignés dans le profil Hypnos correspondant à leur machine.

Conservation des données d'activité :

Les données d'activité de vos clients peuvent être conservées pendant une durée paramétrable (5 ans par défaut) et vous permettent de générer des rapports d'activité .

Les données obsolètes sont supprimées automatiquement chaque jour à minuit.

Inscription automatisée des clients :

Désactivez cette option pour éviter que n'importe quel client non listé dans votre base puisse s'inscrire et ainsi être géré par le serveur s'il en fait la demande.

Gardez cette option activée si vous préférez ne pas avoir à déclarer manuellement vos clients pour qu'ils soient pris en charge par le serveur.

Si vous activez cette option, vous pouvez également choisir d'en faire autant pour les clients venant des réseaux étendus WAN.

Collecter la liste des logiciels installés :

Activez cette option pour permettre à Hypnos Serveur de recenser pour tous vos clients la liste des logiciels installés, ainsi que leur version.

Cette liste s'actualise automatiquement selon la fréquence définie.

Pour limiter le trafic réseau, la liste des logiciels n'est actualisée qu'en cas de changement.

Rémanence des moniteurs :

Lorsqu'un moniteur reste éteint durant le fonctionnement du poste de travail (car généralement d'un écran secondaire, d'un vidéoprojecteur), celui-ci n'est pas détectable par le client Hypnos . Les informations relatives à cet écran peuvent néanmoins être conservées dans la base de données pour une durée réglable. Cet écran restera alors en mémoire durant un certain nombre de jours où l'ordinateur, s'il a été allumé, n'aura néanmoins pas détecté ce moniteur. Si le moniteur est à nouveau détecté, alors le compteur journalier sera réinitialisé. Passé ce délai, le moniteur sera retiré de la base de données.

Ce paramètre permet ainsi de stabiliser les équipements liés aux postes de travail.

Paramétrage manuel de la fréquence des appels clients/serveur :

Afin de signaler sa présence, chaque client transmet régulièrement un appel au serveur afin que ce dernier ne le déconnecte pas.

La mesure de l'inactivité est nécessaire au serveur pour ne pas considérer à tort une connexion comme active dans le cas où cette dernière n'aurait pas été fermée correctement (câble débranché, ordinateur éteint subitement...).

Par défaut en mode automatique, le serveur gère lui-même cet intervalle de rafraîchissement (compris entre 120 et 600 secondes) :

- jusqu'à 120 clients connectés : fixe à 120 secondes,

- au-delà de 120 clients connectés : égal au nombre de clients (sans excéder 600 secondes).

Activez cette option pour passer en mode manuel et fixer le délai entre deux signaux d'activité transmis par chaque client au serveur.

Dans tous les cas, à chaque appel d'un client au serveur, un nouveau délai d'appel lui est indiqué par le serveur, tenant compte du nombre de clients connectés.

  • Réseau

Définissez l'adresse et le masque de votre réseau local LAN pour identifier les connexions qui en proviennent et celles du WAN .

Lorsqu'un client tente une connexion, Hypnos Serveur obtient l'IP de la machine par laquelle la connexion s'établit.

Dans le cas d'une connexion LAN (réseau local), l'IP correspond à l'IP de la machine sur laquelle tourne Hypnos . Cette machine peut éventuellement être allumée à distance directement par Hypnos Serveur .

Dans le cas d'une connexion WAN (réseau étendu), l'IP peut correspondre à une passerelle si la connexion a été initiée depuis un poste appartenant à un autre réseau que celui sur lequel est installé Hypnos Serveur .

Un poste membre du réseau WAN peut éventuellement être allumé à distance par une trame d'éveil transitant par une passerelle WOW .

En modifiant l'adresse ou le masque du réseau local, ou en modifiant la liste des passerelles, l'appartenance de chaque client au réseau LAN ou WAN est recalculée.

Définissez la liste des adresses IP alternatives de connexion à Hypnos Serveur .

Cette liste sera transmise aux clients : en cas d'échec de connexion à l'adresse par défaut, ils tenteront successivement une connexion à chaque IP alternative. En cas de réussite, l'IP deviendra celle par défaut.

Ceci peut s'avérer particulièrement utile si vous prévoyez un changement d'adressage IP sur votre réseau : indiquez la future adresse IP d' Hypnos Serveur à vos clients quelques jours avant, de sorte que chacun puisse disposer de l'adresse alternative. Il ne sera alors pas nécessaire d'intervenir sur chaque poste pour lui attribuer la nouvelle IP d' Hypnos Serveur .

  • Réveil

Déterminez les valeurs par défaut du masque de sous-réseau et de port qui seront utilisés pour les futurs clients inscrits dans la console.

Paramétrez dans le cadre Cadence d'éveil le délai d'envoi entre deux signaux d'éveil programmés pour la même heure.

Afin d'éviter une surcharge électrique due à un trop grand nombre de machines allumées simultanément, les trames d'éveil sont donc envoyées les unes après les autres, au rythme indiqué (au moins toutes les 100 millisecondes).

Selon la taille de votre réseau, vous pouvez augmenter ou diminuer cette valeur.

Configurez également les éveils intelligents : les postes gérés par un éveil intelligent ont leur planning d'éveil recalculé automatiquement chaque jour, tenant compte de leurs horaires d'utilisation.

Indiquez le temps d'allumage de vos ordinateurs pour que ce délai soit pris en compte dans les calculs.

Lorsque, pour chaque semaine écoulée de la période d'analyse définie, un poste est allumé au même horaire, cet horaire est ajouté au planning d'éveil.

Inversement si un horaire planifié n'est plus suivi d'un allumage durant la période d'analyse, il est déprogrammé.

Ainsi, le profil d'éveil s'ajuste en fonction de l'utilisation du poste, afin de limiter les éveils inutiles, tout en préservant le confort de travail des usagers.

  • Licence & Internet

Indiquez les paramètres de votre serveur proxy si vous en utilisez un pour vous connecter à Internet (par exemple : 172.16.0.1:3128).

Cette donnée est utilisée par Hypnos Serveur pour rechercher la présence de mises à jour et pour communiquer périodiquement avec le serveur de licence.

Si vous laissez décochée la case Serveur Proxy, vous indiquez à Hypnos Serveur d'utiliser le mode de connexion Internet configuré sur votre ordinateur.

Si vous cochez la case Serveur Proxy, vous indiquez à Hypnos Serveur d'utiliser un proxy (éventuellement vide).

Pour les mises à jour d' Hypnos Serveur , vous pouvez soit :

- Ignorer : aucun test automatisé de mise à jour ne sera effectué par Hypnos Serveur.

- Avertir en cas de mise à jour (valeur par défaut) : un test de mise à jour sera effectué toutes les 24 heures et vous serez averti lorsqu'une mise à jour sera disponible (infobulle dans la zone de notification + message clignotant dans l'application).

- Télécharger et installer : un test de mise à jour sera effectué toutes les 24 heures. Si une mise à jour est disponible depuis au moins 10 jours, alors elle sera téléchargée et installée automatiquement.

- Tester pour vérifier manuellement l'existence d'une mise à jour.

Consultez la page Licence pour connaître les différents types de licences proposées.

  • Hypnos Manager

Grâce à Hypnos Manager, exploitez de façon personnalisée les données de connexion journalières de vos clients Hypnos ainsi que ceux gérés par d'autres serveurs Hypnos en les stockant sur une base de données externalisée.

Vous pouvez paramétrer l'envoi des données à 2 serveurs Hypnos Manager.

A Hypnos Manager, Hypnos Serveur transmet :

- le mode de fonctionnement des profils : normal ou en maintenance

- le mode choisi des mises à jour : désactivé, manuel, automatique

- pour chaque client : les données indiquées dans le volet informations

- pour chaque jour révolu depuis l'installation d' Hypnos Serveur et pour chaque client : son temps de fonctionnement, son temps d'utilisation (utilisateur connecté), son temps de fonctionnement économisé par Hypnos , le nombre d'arrêts réalisés par Hypnos et les minutes de première et dernière activités de la journée

- le paramétrage de chaque profil Hypnos utilisé

- le paramétrage de chaque profil d'éveil utilisé

- le paramétrage de chaque régime de vacances utilisé

- la liste des logiciels installés sur chaque client

- la liste des moniteurs connus pour le client

- selon la configuration d'Hypnos Manager, la base de données d' Hypnos Serveur pour archivage

- l'heure courante

Si vous gérez votre propre site (PHP & MySQL) :

- téléchargez Hypnos Manager et décompressez l'archive sur votre disque dur,

- modifiez le fichier includes/connect.php en précisant les paramètres de connexion à votre base de données,

- copiez l'ensemble des fichiers dans un répertoire dédié de votre site, et ouvrez dans votre navigateur l'URL correspondante,

- connectez-vous avec le mot de passe par défaut : admin,

- créez un établissement,

- renseignez dans Hypnos Serveur l'URL du script et le code de transmission d'identification du site créé,

- cliquez sur Envoyer pour transmettre les données de connexion de vos clients au serveur.

Si une URL et un code de transmission vous ont été transmis par un tiers :

- renseignez ces informations dans les champs correspondants

- cliquez sur Envoyer pour transmettre les données de connexion de vos clients au serveur.

Hypnos Serveur transmet chaque nuit au(x) serveur(s) Hypnos Manager les données de connexion de tous les clients.

La liste des postes en suivi continu vous indique ceux pour lesquels leur état (allumé / éteint) est transmis toutes les 10 minutes à Hypnos Manager pour être prévenu des pannes éventuelles.

Cette fonctionnalité s'adresse principalement aux postes serveurs qui requièrent un service en continu.

Exemple : Rendez-vous sur https://hypnos.soft-micro.fr/manager/ .

  • Calcul des économies

Lorsqu'une station est arrêté automatiquement par Hypnos , le temps écoulé jusqu'à sa prochaine activité est considéré comme une économie.

Paramétrez ici la façon dont les données de calcul des économies affichées en page d'accueil et dans les rapports d'activité sont récupérées.

    • Soit les données sont gérées par un script :

Dans ce cas, un appel est effectué quotidiennement à l'URL que vous mentionnerez afin de récupérer le informations de paramétrage.

Vous pouvez cliquer sur [image] pour voir un exemple de script PHP permettant la récupération de données.

    • Soit les données sont gérées par Hypnos Manager (serveur 1 ou serveur 2) : la mise à jour est quotidienne

    • Soit les données sont gérées manuellement :

Ces données incluent :

      • La puissance moyenne de vos stations (en Watts)
      • Le prix du kWh (en € ou en $)
      • Le plafond d'économies après un arrêt Hypnos (en jours):

Cette donnée est utilisée dans le cas où une station, arrêtée par Hypnos, n'est plus utilisée pendant une très longue durée.

Le temps écoulé depuis son arrêt étant pris en compte comme une économie, le plafond est la durée maximale, en jours, au terme de laquelle vous considérez raisonnablement que la station aurait été éteinte manuellement par un tiers.

Ce paramétrage évite que des postes retirés du réseau, en panne, ou tout simplement inutilisés durant une longue période, engendrent une estimation d'économie démesurée.

  • Contrôle à distance

Sélectionnez dans cette page l'exécutable de l'utilitaire de contrôle à distance que vous utilisez habituellement pour vous connecter aux postes clients Hypnos .

Précisez dans les paramètres la ligne de commandes permettant de préciser l'IP du poste cible (utiliser le symbole * pour désigner l'IP).

Note : Hypnos Serveur ne contient aucun logiciel de prise en main à distance et ne sert que d'interface pour prendre en main vos stations avec votre utilitaire de contrôle distant.

  • Tâches

Définissez dans cette rubrique le fonctionnement de la page Tâches :

    • Indiquez si l'utilisateur doit confirmer avant l'exécution ou l'interruption d'une tâche.

    • Choisissez si les clients cibles hors ligne devront être réveillés par WOL en début de tâche (ceci peut être utile notamment si vous utilisez la planification des tâches ).

    • Choisissez le délai au-delà duquel une action restée sans réponse par un client provoque l'abandon de l'exécution de la tâche pour ce client.

    • Vous pouvez activer la purge automatique de l'historique des tâches exécutées au terme du délai choisi.

Note : Depuis la page Tâches , vous avez toujours la possibilité de supprimer manuellement l'historique des tâches exécutées.

    • L'accès à la page Tâches peut être contrôlé par une demande de code d'accès : ceci permet d'éviter qu'un administrateur local utilisateur d' Hypnos Serveur ne prenne connaissance des détails des actions des tâches enregistrées, lesquels peuvent comporter, notamment, des mots de passe ou des informations confidentielles du domaine.

Lorsqu'un code d'accès est défini, les tâches sont cryptées avec ce dernier dans la base de données d' Hypnos Serveur : chaque utilisateur accédant à la page Tâches doit renseigner le code d'accès pour accéder à son contenu. Une fois le code d'accès correctement renseigné, la page Tâches se reverrouille automatiquement à la réduction de la fenêtre d' Hypnos Serveur en zone de notification, ou après une inactivité d'une heure.

Le code d'accès peut être modifié à tout moment : les tâches enregistrées sont alors cryptées avec le nouveau code d'accès.

Sauf si aucune tâche n'est enregistrée, vous devez fournir l'ancien code d'accès pour en définir un nouveau.

En cas de perte du code d'accès, Hypnos Serveur vous proposera de supprimer toutes les tâches en mémoire lorsque vous tenterez de le modifier : vous perdrez alors les données des tâches enregistrées, mais vous pourrez à nouveau créer et crypter des tâches.

  • Séparateurs

Choisissez les séparateurs utilisés dans vos fichiers CSV : séparateur de champ (virgule ou point virgule) et séparateur décimal (point ou virgule).

Indiquez également le séparateur utilisé pour afficher les adresses MAC : aucun (000000000000), deux points (00:00:00:00:00:00) ou tiret (00-00-00-00-00-00).

  • Journal des événements

Afin d'avoir un fichier d'historique consignant les événements liés notamment aux connexions & déconnexions de vos clients, choisissez le nom de fichier, puis le niveau de verbosité :

- Aucune pour désactiver la journalisation

- Basique / Normale / Détaillée pour régler le détail des informations consignées : seul le niveau de verbosité Détaillée indique les requêtes réalisées sur la base de données.

Enfin, choisissez une taille maximale du fichier de journalisation (entre 1 et 100 Mo) : une fois cette taille atteinte, le fichier sera tronqué à 90% de sa taille en ne conservant que les éléments les plus récents pour y adjoindre ceux à venir sans dépasser la taille demandée.

  • Import / Export

Vous pouvez sauvegarder l'ensemble de vos données (clients, profils, etc.) dans un fichier choisissant d'Exporter la configuration.

Inversement, récupérez les données d'un précédent export, en choisissant d'Importer le fichier correspondant.

Les données importées écraseront alors les données courantes : il est donc recommandé d'exporter le contenu de vos données avant d'effectuer cette opération.

  • Langue clients / serveur

Vous pouvez choisir la langue affichée dans les clients Hypnos et dans Hypnos Serveur .


Hypnos Client

Hypnos ››

Hypnos vous permet d'éteindre vos ordinateurs au bout d'un certain délai d'inactivité, afin d'économiser des heures de fonctionnement inutile.

Hypnos contrôle l'inactivité de l'ordinateur même si aucune session n'est ouverte.

Paramétrez Hypnos en accédant aux différents onglets de l'application par un clic sur l'icône [image] située en zone de notification, près de l'horloge :

    1. Configuration (mode de fonctionnement, mot de passe, langue)

    2. Options d'arrêt (délai avant arrêt, fermeture, ...)

    3. Ecran de veille et Alimentation

    4. Icône en zone de notification

    5. Compte à rebours

Note : Ces options ne sont accessibles que si vous disposez des droits d'administration de l'ordinateur et que l'application n'est pas protégée par mot de passe .


Configuration

Hypnos ›› Hypnos Client ››

La page Configuration vous permet d'effectuer les réglages généraux de l'application :

  • Choisissez le mode de fonctionnement d'Hypnos :
    • Autonome : si vous souhaitez gérer vous-même les options du logiciel et le faire fonctionner de façon indépendante,
    • Géré par un serveur : si vous utilisez Hypnos Serveur pour manager plusieurs ordinateurs comme clients Hypnos, et ainsi centraliser leur configuration depuis le serveur : ainsi, vous n'avez plus aucun réglage à effectuer sur Hypnos.

Veillez à ce que votre pare-feu ne bloque pas le port 12768 de votre ordinateur afin de pouvoir établir une liaison entre les deux ordinateurs.

Indiquez le nom du serveur ou cliquez sur [image] pour lancer une recherche automatique (cette recherche peut s'avérer longue selon le nombre d'ordinateurs connectés sur votre réseau).

Si votre ordinateur est membre d'un domaine, vous pouvez cocher la case Contrôleur principal de domaine si Hypnos Serveur est installé sur ce dernier.

Note : Une fois vos réglages enregistrés, Hypnos tente de contacter le serveur et affiche en permanence l'état de la connexion par l'icône [image] ou [image] .

  • Déterminez un mot de passe afin de filtrer l'accès aux options du logiciel.

Ce mot de passe vous sera demandé à chaque ouverture de la fenêtre de configuration d'Hypnos.

  • Choisissez enfin la langue de l'application.

En bas de page, le bandeau d'actions est proposé :

  • Cliquez sur Enregistrer pour valider vos réglages.
  • Réduire permet de minimiser l'application en zone de notification, sans enregistrer les modifications de paramétrage.
  • Stopper arrête le service Hypnos et le processus Hypnos de chaque session ouverte, jusqu'au prochain redémarrage de l'ordinateur.
  • Le bouton d'Aide vous renvoie vers le présent fichier d'aide.


Options d'arrêt

Hypnos ›› Hypnos Client ››

Dans la page Options d'arrêt, accédez aux options principales d'Hypnos :

  • Arrêt du poste

Activez cette option pour qu'au terme du délai d'inactivité choisi Hypnos arrête votre ordinateur.

Choisissez le mode d'arrêt de votre convenance : soit l'arrêt du système, soit la mise en veille prolongée (hibernation).

Juste avant la fermeture, une fenêtre avec compte à rebours s'affichera.

Note : Sur Hypnos Client , le bouton de mise en veille prolongée sera grisé si la mise en hibernation n'est pas autorisée ou incompatible avec votre système. Vous pouvez autoriser la mise en veille prolongée depuis les Options d'alimentation du Panneau de Configuration.

  • Horaires de contrôle quotidien pour l'arrêt du poste

Précisez la plage horaire quotidienne (zone verte) de contrôle de l'inactivité pour l'arrêt du poste.

En dehors de cette plage horaire (zone rouge), Hypnos n'arrêtera pas l'ordinateur en raison de son inactivité.

Exemples :

    • Précisez un fonctionnement de 17:00 à 08:00 pour que :

- de 08:00 à 17:00 (zone rouge), Hypnos n'arrête pas l'ordinateur,

- de 17:00 à 08:00 le lendemain (zone verte), le contrôle d'inactivité soit effectif.

    • Laissez le paramétrage 00:00 à 23:59 pour que le logiciel contrôle l'inactivité de votre ordinateur en continu.

Cochez la case Contrôler en permanence lorsqu'aucune session n'est ouverte, si, quand aucun utilisateur n'a ouvert de session, vous souhaitez autoriser Hypnos à arrêter le poste sans tenir compte des horaires.

  • Arrêt de session

En activant cette option, vous autorisez Hypnos à fermer ou verrouiller toute session ouverte et inactive durant le délai spécifié.

  • Fermer même si fenêtre plein écran

Laissez cette case décochée si vous souhaitez qu'Hypnos ne ferme pas vos applications en cas d'inactivité si l'application active est en mode plein écran, par exemple lors du visionnage d'un film.

Cochez cette case si vous souhaitez autoriser l'arrêt malgré la présence d'une fenêtre ouverte en plein écran.

  • Forcer la procédure d'arrêt

En cochant cette case, Hypnos indiquera à Windows de fermer le système ou la session même si une application lui propose de l'annuler. Ceci peut arriver lorsqu'un travail non enregistré est ouvert dans un éditeur.

Si vous activez cette option, les données non enregistrées de ces applications risqueront donc perdues.

  • Contrôle l'utilisation du processeur

Le contrôle de l'utilisation du processeur vous permet de fixer le pourcentage d'utilisation du processeur, le seuil d'activité qui, s'il est dépassé, sera assimilé par Hypnos comme une activité et reportera ainsi la fermeture du système.

Un seuil fixé trop bas aura pour conséquence de la reporter continuellement.

Un seuil trop élevé sera sans effet.

Cette option peut être utile sur des ordinateurs employés pour des traitements longs de données durant lesquels ils ne doivent pas être interrompus.


Ecran de veille et Alimentation

Hypnos ›› Hypnos Client ››

Hypnos vous permet de paramétrer le fonctionnement de l'écran de veille et la gestion de certains paramètres d'alimentation.

Ces options s'adressent principalement aux utilisateurs d' Hypnos Serveur .

  • En cochant la case Gérer l'écran de veille, Hypnos configurera l'écran de veille choisi pour tous les utilisateurs de l'ordinateur.
    • Vous pouvez spécifier l'écran de veille de votre choix en indiquant le nom du fichier voulu (exemple : Mystify pour l'écran de veille Ballet de lignes).
    • Précisez le délai d'inactivité avant son déclenchement, et si vous souhaitez protéger la sortie de veille par la demande du mot de passe de l'utilisateur.

Note : En utilisant cette option, les utilisateurs ne pourront plus configurer leur écran de veille.

  • Cochez la case Gérer les paramètres d'alimentation, pour le réguler comportement énergétique de votre ordinateur :
    • Plan d'alimentation de base (compatible dès Windows Vista) : sélectionnez le plan d'alimentation de référence de votre ordinateur qui sera utilisé par Hypnos (Performances maximales, Usage normal, Economies d'énergie).
    • Mise en veille du moniteur : indiquez la durée d'inactivité avant mise en veille de l'écran de l'ordinateur
    • Arrêt des disques durs : indiquez le durée d'inactivité avant l'arrêt des disques durs
    • Action du bouton d'alimentation : précisez le comportement de votre machine lorsqu'un utilisateur appuie sur le bouton d'alimentation
    • Action du bouton de mise en veille : précisez le comportement de votre machine lorsqu'un utilisateur appuie sur le bouton de mise en veille
    • Mise en veille de l'ordinateur : choisissez le délai d'inactivité avant la mise en veille de votre ordinateur et, éventuellement, cochez la case A la sortie de veille, protéger par mot de passe.

Note : En utilisant cette option, les utilisateurs ne pourront plus configurer les paramètres d'alimentation.


Icône en zone de notification

Hypnos ›› Hypnos Client ››

La page Icône en zone de notification vous permet de définir les actions possibles depuis le menu contextuel de l'icône [image] près de l'horloge.

Le menu contextuel permet de :

  • Désactiver l'arrêt automatique de l'ordinateur pour plusieurs heures en cas de longue opération de traitement initiée sur le poste. L'icône en zone de notification devient alors [image] .

Au terme de ce délai, au redémarrage de l'ordinateur, ou encore en cliquant sur Réactiver l'arrêt automatique, Hypnos reprend son fonctionnement normal.

  • Configurer Hypnos : l'accès aux options est réservé aux administrateurs de l'ordinateur, et peut être protégé pat mot de passe .

Dans la page Icône en zone de notification, vous pouvez :

  • Paramétrer la durée maximale de suspension des arrêts automatiques : 4 heures, 12 heures, 24 heures ou 48 heures.

  • Interdire à certains utilisateurs l'accès au menu contextuel : pour cela, indiquez dans le panel Groupes non autorisés, les groupes d'utilisateurs pour lesquels vous souhaitez empêcher l'accès au menu contextuel depuis l'icône en zone de notification.

    • Sélectionnez les groupes d'utilisateurs auxquels vous souhaitez interdire l'accès aux options d'Hypnos. Cliquez sur le bouton de rafraîchissement [image] pour actualiser cette liste à tout moment.
    • Validez votre sélection en cliquant sur [image] : les groupes sélectionnés sont alors ajoutés aux groupes d'exclusions.
    • Si votre ordinateur n'est pas encore membre d'un domaine ou si un groupe à exclure n'existe pas encore, vous pouvez faire l'ajout manuellement.

Note : Veillez à ne pas inclure aux groupes d'exclusions un groupe auquel vous appartenez, sans quoi vous ne parviendrez plus à accéder aux paramétrage d'Hypnos.


Compte à rebours

Hypnos ›› Hypnos Client ››

Paramétrez dans cette page, les options du compte à rebours.

  • Indiquez le message que vous souhaitez montrer lors de l'affichage de la fenêtre du compte à rebours avant l'arrêt de l'ordinateur ou la fermeture de la session.

Utilisez dans le message, la marque $n pour indiquer là où vous souhaitez voir apparaître le compte à rebours.

  • Paramétrez la durée d'affichage de la fenêtre du compte à rebours.

Indiquez une durée égale à 0 pour désactiver l'affichage de cette fenêtre.

  • Enfin, cochez la case Jouer un son pour prévenir, afin d'émettre un beep lorsque la fenêtre de compte à rebours s'affichera :
    • sur les haut-parleurs de la carte son à 50 s, 40 s, 30 s, 20 s puis 10 s avant la fermeture.
    • sur le haut-parleur interne du PC à 15 s puis 5 s avant la fermeture.

Note : Selon la version de votre système d'exploitation, le son envoyé sur le haut-parleur interne peut être automatiquement redirigé par le système vers la carte son par défaut.

  • Lorsque le compte à rebours s'affiche, l'économiseur d'écran s'arrête s'il était en fonctionnement.


Ligne de commandes

Hypnos ›› Hypnos Client ››

L'exécutable Hypnos.exe peut être lancé avec différentes options en ligne de commandes :

Hypnos.exe [/n | /U | /u ]

/n : Installe le client dans le dossier de l'exécutable

/U : Désinstalle le client (demande de confirmation à l'utilisateur)

/u : Désinstalle le client (mode silencieux)

Ces commandes peuvent être utilisées pour automatiser l'installation ou la désinstallation d' Hypnos Client .

Le déploiement automatisé par GPO propose des options supplémentaires.


Déploiement automatisé

Le client Hypnos peut être déployé de façon automatisée par le système d'exploitation à tout ou partie de votre domaine (installation ou désinstallation du client).

L'exécutable HypnosSetup_svc.exe présent dans le répertoire d'installation d' Hypnos Serveur permet ceci par la syntaxe suivante :

HypnosSetup_svc.exe [/i | /f | /u] [/s:serveur]

/i : Installe le client

/f : Installe le client uniquement si une version 2 ou ultérieure n'est pas installée ou si le nom du serveur précisé en paramètre /s n'est pas celui trouvé sur le poste

/u : Désinstalle le client

/s : Utilisé avec /i ou /f, permet de préciser le nom NETBIOS du poste hébergeant Hypnos Serveur pour configuration du client.

Exemple :

La commande suivante installe le client s'il n'est pas déjà présent (en version 2 ou ultérieure) et le fait pointer vers le serveur PDC1 :

HypnosSetup_svc.exe /f /s:PDC1

Le client Hypnos peut être installé directement avec d'autres options en ligne de commandes .

En mettant en partage le répertoire d'installation d' Hypnos Serveur - par exemple un partage caché Hypnos$ -, vous pouvez mettre en place différentes méthodes de déploiement :

  • Déploiement automatisé par GPO (Group Policies Object) :

Sur un serveur Windows, la mise en place d'une GPO utilisant la commande précédente permet d'avoir le client Hypnos installé et à jour sur tous les postes ciblés par la GPO.

  • Déploiement automatisé par WPKG :

Si WPKG est installé sur votre domaine, vous pouvez créer le package Hypnos.xml selon le modèle suivant (il vous suffit alors de personnaliser les valeurs PDC1 et Hypnos$) :

<?xml version="1.0" encoding="UTF-8"?>

<packages>

<package id="Hypnos" name="Hypnos client" revision="%version%.1" reboot="false" priority="100">

<variable name="Serveur_Hypnos" value="PDC1"/> <!-- Indique le nom du serveur du partage -->

<variable name="Partage" value="Hypnos$" /> <!-- Indique le nom du partage -->

<variable name="version" value="3.0.0.0" />

<variable name="PROGRAMFILES" value="%PROGRAMFILES%" architecture="x86"/>

<variable name="PROGRAMFILES" value="%PROGRAMFILES(X86)%" architecture="x64"/>

<check type='file' condition='versiongreaterorequal' path="%PROGRAMFILES%\Hypnos\Hypnos.exe" value="%version%" />

<install cmd='"\\%Serveur_Hypnos%\%Partage%\HypnosSetup_svc.exe" /f /s:%Serveur_Hypnos%' />

<remove cmd='"%PROGRAMFILES%\Hypnos\Hypnos.exe" /u' />

</package>

</packages>

Pour indiquer dans un profil WPKG d'installer Hypnos, il suffit de l'ajouter via WPKG-Manage , ou d'ajouter manuellement dans le fichier correspondant :

<package package-id="Hypnos"/>


Licence

Hypnos Serveur se décline en trois licences :

  • Version d'évaluation :

Cette version est activée lors de la première installation d' Hypnos Serveur et permet une utilisation sans restriction de l'application pour une durée de 30 jours. A l'issue de cette période probatoire, vous devez obtenir une licence d'utilisation (payante) pour basculer en version enregistrée, sans quoi la version d'évaluation expirera et basculera automatiquement en version gratuite.

  • Version gratuite :

Cette version est limitée à 15 clients gérés par Hypnos Serveur mais n'est pas limitée en durée.

  • Version enregistrée :

Cette version (payante) comprend une licence nominative permettant à un nombre maximum de clients de se connecter à Hypnos Serveur .

Cette licence n'est utilisable que sur le système hébergeant Hypnos Serveur lequel vérifie périodiquement la validité de la licence auprès du serveur de licence.

Vous avez la possibilité d'utiliser Hypnos Serveur sur autant de systèmes différents que de licences acquises.

Chaque appel au serveur de licence vise à renouveler pour une période de deux mois la validité de la licence acquise, afin de protéger les acquéreurs contre les risques de copie illégale du logiciel.

En cas de changement de composants matériels ou du système, il peut être nécessaire de réactualiser les informations de licence auprès du serveur de licence.

Plusieurs options (payantes) sont également disponibles :

  • Actions de commandes et de fichiers :

Exécutez et programmez des actions de transfert de fichiers et d'exécution de commandes sur vos clients Hypnos .

  • Recensement dynamique des logiciels :

La liste des logiciels installés sur vos clients Hypnos est régulièrement recensée (nom du logiciel, version, date d'installation).

  • Recensement dynamique des moniteurs :

Les caractéristiques des moniteurs raccordés aux clients Hypnos sont enregistrées à chaque connexion (marque, modèle, taille, numéro de série, date de fabrication).

Toutes les options sont disponibles en version d'évaluation.

Note importante : Les données indiquées sur cette page sont susceptibles d'avoir évolué et sont données à titre indicatif. Consultez cette page pour obtenir les dernières informations contractuelles.


Historique

  • Version 3.3.2.3 du 01-01-23 :
    • Mise à jour des dates de vacances scolaires

  • Version 3.3.2.2 du 27-10-22 :
    • Améliorations ergonomiques
    • Ajout de la zone de vacances Corse

  • Version 3.3.2.1 du 16-10-21 :
    • Mise à jour des dates de vacances

  • Version 3.3.2.0 du 19-09-20 :
    • Possibilité de définir un alias de nom pour chaque client

  • Version 3.3.1.7 du 12-09-20 :
    • Les clients munis de plusieurs cartes réseau ne sont plus comptabilisés comme différents s'ils se connectent depuis plusieurs cartes réseau

  • Version 3.3.1.6 du 09-03-20 :
    • Correction d'une anomalie qui pouvait survenir en cas de changement d'un poste utilisé comme poste relais pour les éveils

  • Version 3.3.1.5 du 06-12-19 :
    • Correction d'une anomalie de fonctionnement qui pouvait survenir au moment de la sélection d'une date sur Hypnos Serveur
    • Correction d'une erreur mineure sur Hypnos qui effaçait des paramètres le nom d'hôte d' Hypnos Serveur en cas de non réponse DNS si le nom d' Hypnos Serveur était donné comme nom d'hôte et non comme IP (le client ne pouvait plus se reconnecter une fois le DNS rétabli)

  • Version 3.3.1.4 du 10-08-19 :
    • Mise à jour des dates de vacances scolaires des zones A, B et C

  • Version 3.3.1.3 du 10-05-19 :
    • Prise en charge du bouton de mise en veille dans les profils Hypnos
    • Mise à jour des dates de vacances scolaires des zones A, B et C
    • Correction d'une anomalie dans le recensement des logiciels (certains anciens logiciels désinstallés pouvaient rester en mémoire)

  • Version 3.3.1.2 du 05-05-19 :
    • Transmission de l'heure courante à Hypnos Manager
    • Correction d'une anomalie qui empêchait la mémorisation de la disposition des éléments dans l'onglet des Tâches
    • Correction d'une anomalie qui pouvait empêcher l'enregistrement des activités de connexion
    • Correction d'une anomalie qui pouvait survenir à la réduction de la fenêtre en zone de notification quand une tâche n'était pas enregistrée

  • Version 3.3.1.1 du 09-02-19 :
    • Correction d'une anomalie pouvant empêcher l'envoi des données des moniteurs à Hypnos Manager sous certaines conditions

  • Version 3.3.1.0 du 06-02-19 :
    • Les dimensions et le ratio des moniteurs sont désormais recensés
    • Configuration de la durée de rémanence des moniteurs , afin de les conserver dans la base de données pendant un temps, même s'ils sont inutilisés
    • Affichage pour chaque client du nom du dernier utilisateur connecté
    • Les exports des clients incluent désormais le nom du dernier utilisateur connecté, le nom précédent du poste (si connu), le nom des profils ( Hypnos , éveil , suivi continu )
    • Améliorations mineures d'affichage et d'ergonomie
    • Amélioration du protocole d'envoi des données à Hypnos Manager
    • Correction d'une anomalie qui pouvait survenir durant l'attribution d'un profil à plusieurs clients
    • Correction d'une anomalie qui pouvait survenir lors de l'assignation d'un serveur en suivi sur Hypnos Manager

  • Version 3.3.0.3 du 17-09-18 :
    • Correction d'une anomalie pouvant empêcher la mise à jour sur certains systèmes où le proxy du compte SYSTEM LOCAL n'était pas renseigné

  • Version 3.3.0.2 du 13-09-18 :
    • Correction d'une anomalie pouvant empêcher la bonne exécution d'une action de commande de tâche
    • Corrections visuelles mineures

  • Version 3.3.0.1 du 05-09-18 :
    • Correction d'une anomalie pouvant empêcher l'accès à Internet sur certains systèmes où le proxy du compte SYSTEM LOCAL n'était pas renseigné
    • Correction d'une anomalie dans le tri des moniteurs

  • Version 3.3.0.0 du 02-09-18 :
    • L'utilisation des tâches et le recensement des logiciels sont désormais des options de licence
    • Recensement des moniteurs raccordés aux clients ( option de licence )
    • Possibilité de basculer en maintenance temporaire et non pas seulement permanente
    • Possibilité de modifier la durée de suspension des arrêts d' Hypnos par les utilisateurs
    • Meilleure ventilation des clients en attente lors de l'exécution d'une tâche
    • Amélioration des limitations des tâches en fonctionnement simultané
    • Le passage à l'action suivante d'une tâche n'attend pas la fin du délai imparti si la fenêtre de message est fermée par l'utilisateur.
    • La langue et le mot de passe des clients Hypnos sont désormais gérés de façon globale et non plus individuellement par chaque profil Hypnos
    • Sur le client, le clic sur le bouton Stopper arrête désormais le service et les applications Hypnos et non pas seulement l'application Hypnos de la session active
    • Le menu Renommer n'apparaît plus désormais pour un client lorsque son adresse MAC est connue
    • Améliorations mineures d'ergonomie dans Hypnos Serveur et le client Hypnos
    • Ajout d'un message proposant d'exporter la configuration courante avant un import
    • Ajout de la possibilité de réinitialiser en un clic les horaires intelligents d'un ou plusieurs profils d'éveil
    • Améliorations ergonomiques des tâches
    • Actualisation des dates de vacances scolaires
    • Correction d'une anomalie qui pouvait empêcher l'interruption d'une tâche active
    • Correction d'une anomalie qui pouvait démarrer deux fois consécutivement la même action dans une tâche sous certaines conditions
    • Correction d'une anomalie mineure des tâches qui pouvait inclure dans les cibles les clients dont l'adresse MAC était inconnue
    • Correction d'une anomalie qui pouvait ne pas enregistrer les modifications apportées sur une tâche dans certaines conditions
    • Correction du tri automatique des clients des tâches , lorsque les clients étaient classés par profil Hypnos ou par profil d'éveil
    • Correction d'une anomalie dans l'export CSV des clients sélectionnés

  • Version 3.2.0.8 du 13-05-18 :
    • Ajout de la possibilité de désactiver une action dans une tâche
    • Amélioration de la gestion du presse-papiers pour couper / coller des clients afin de les changer de dossier
    • Correction d'une anomalie d'exécution des tâches qui pouvaient ne pas se poursuivre après redémarrage de l'ordinateur
    • Correction de défauts ergonomiques dans l'utilisation des tâches et le changement de pages
    • Correction du tri automatique des clients des tâches, qui ne s'initialisait pas au lancement de l'application
    • Correction d'une anomalie mineure d'encodage dans la création des fichiers CSV d'export des clients
    • Correction d'une anomalie mineure d'encodage dans l'import des fichiers de tâches

  • Version 3.2.0.7 du 25-04-18 :
    • Affichage du nom précédent de la machine cliente si elle a été renommée
    • Possibilité de paramétrer les séparateurs des fichiers CSV et des adresses MAC en page Configuration
    • La suppression d'un dossier de clients propose désormais de déplacer les clients à la racine plutôt que de les supprimer
    • Affichage du nom des utilisateurs connectés sur les clients dans l'arborescence des cibles des Tâches
    • Améliorations visuelles dans le classeur d'actions des Tâches
    • Améliorations ergonomiques mineures
    • Correction d'une erreur dans le tri des clients
    • Correction d'une anomalie pouvant survenir durant le paramétrage d'un profil Hypnos

  • Version 3.2.0.6 du 21-03-18 :
    • Correction d'une anomalie d'affichage

  • Version 3.2.0.5 du 18-03-18 :
    • Amélioration de la méthode de compression / décompression des archives ZIP et des fichiers d'import / export
    • Amélioration de la méthode d'envoi de l'état des clients suivis à Hypnos Manager
    • Ajout de la possibilité d'explorer le disque dur d'un client du réseau local depuis le menu contextuel des clients
    • Possibilité d'exécuter une action d'attente dans les tâches
    • Correction d'une anomalie pouvant empêcher l'affichage de la fenêtre d' Hypnos Serveur dans le cas où elle était en dehors de la zone d'affichage du moniteur
    • Correction d'une anomalie qui pouvait figer le client dans l'exécution de certaines tâches
    • Corrections mineures d'ergonomie

  • Version 3.2.0.1 du 24-02-18 :
    • Correction d'une anomalie qui pouvait survenir en cas de lancement simultané de plusieurs tâches de transferts de fichiers sur le même client
    • Correction d'un défaut d'affichage dans la page des tâches

  • Version 3.2.0.0 du 22-02-18 :
    • Possibilité de programmer des tâches comportant un ensemble d'actions personnalisables sur des machines ciblées : envoi / réception de fichiers, exécution de commandes, envoi d'un message aux utilisateurs, compression / décompression de fichiers
    • L'arrêt de session est désormais indépendant des horaires indiqués pour l'arrêt du poste
    • Lors de la modification des informations de définition du réseau local ou des passerelles, l'appartenance de chaque client au réseau LAN / WAN est désormais recalculée automatiquement
    • Amélioration de la méthode d'envoi de l'état des clients suivis à Hypnos Manager
    • Correction d'une anomalie qui limitait le nombre de postes marqués comme allumés alors qu'il pouvait y en avait davantage
    • Correction d'une anomalie qui pouvait engendrer la déconnexion temporaire des clients lors du changement de leur configuration
    • Correction d'une anomalie pour laquelle la liste des clients suivis n'était pas actualisée lorsqu'un client en suivi rapproché était supprimé ou renommé
    • Correction d'une anomalie d'affichage où un client éteint pouvait paraître allumé
    • Correction d'une anomalie d'affichage dans la liste des logiciels installés, en cas d'actualisation lorsque le tri n'était pas sur la première colonne
    • Correction d'une anomalie dans la prise en compte des IP alternatives

  • Version 3.1.1.0 du 13-12-17 :
    • Correction d'une anomalie d'ergonomie pouvant survenir lors des réglages avec certains composants
    • Correction d'une anomalie dans la prise en compte des IP alternatives

  • Version 3.1.0.10 du 07-12-17 :
    • Amélioration de la procédure de suivi rapproché des clients ciblés
    • Possibilité de définir le masque et le port d'éveil par défaut dans l'onglet Configuration
    • Modification des jeux de couleurs ( client utilisé / hors session )
    • Modification du profil initial "Aucun arrêt" pour activer la gestion des paramètres d'alimentation
    • Amélioration de la connectivité clients / serveur
    • Correction d'une erreur qui empêchait un éveil distant de fonctionner lorsqu'il transitait par un client relais
    • Correction d'affichage dans la console où le caractère & était mal pris en compte

  • Version 3.1.0.9 du 29-10-17 :
    • Amélioration de la prise en compte des IP alternatives dans Hypnos Client lorsqu'elles sont couplées à une mise à jour

  • Version 3.1.0.8 du 26-10-17 :
    • Possibilité de déterminer des adresses IP alternatives pour accéder à Hypnos Serveur
    • Possibilité de définir des clients suivis par Hypnos Manager
    • Suppression de la possibilité de définir automatiquement le contrôleur principal de domaine comme serveur par défaut dans Hypnos Client
    • Amélioration de la communication entre l'application et le service du serveur
    • Correction d'un bug qui pouvait empêcher de désactiver des profils d'éveil
    • Retrait d'un bip au démarrage du service

  • Version 3.1.0.6 du 15-10-17 :
    • Les rapports globaux mentionnent désormais le nombre de sessions ouvertes durant la période
    • Amélioration de la communication entre l'application et le service du serveur
    • Correction d'affichage du nombre d'arrêts indiqué en infobulle au survol du graphique et qui pouvait être incorrect
    • Correction de l'export des données des clients (les commentaires n'apparaissaient pas convenablement, le fichier généré pouvait être vide)
    • Correction d'une anomalie mineure d'affichage dans le panel des informations clients

  • Version 3.1.0.5 du 25-09-17 :
    • La suspension par un utilisateur des arrêts automatisés est désormais plafonnée à 4 heures
    • Correction d'une anomalie survenant lors de la mise à jour d' Hypnos Client , pouvant réenclencher les arrêts automatisés alors qu'ils avaient été suspendus par un utilisateur
    • Mise à jour des dates de vacances des zones A, B, C jusqu'en septembre 2019
    • Modification de la procédure de démarrage avec Windows
    • Amélioration de la procédure de déploiement
    • Mise à jour de la librairie de cryptage pour l'envoi des données de licence

  • Version 3.1.0.2 du 16-09-17 :
    • Prise en charge complète des systèmes où le contrôle des comptes utilisateurs (UAC) est activé
    • Le masque d'éveil par défaut est désormais 255.255.255.255 contre x.x.255.255 au préalable
    • La méthode d'éveil distant précédant le déploiement a été améliorée
    • La date d'installation des logiciels installés sur les clients est désormais collectée, ainsi que l'architecture du système d'exploitation (32 ou 64 bits)
    • Possibilité de définir l'adresse et le masque du réseau pour mieux identifier les IP provenant du LAN et celle du WAN
    • Possibilité de définir deux serveurs Hypnos Manager
    • Correction d'un bug mineur d'affichage dans la fenêtre de code PHP
    • Correction d'un bug qui installait les nouvelles versions d' Hypnos Serveur dans le dossier d'installation par défaut et non celui choisi par l'utilisateur dans le cas où ceux-ci étaient différents

  • Version 3.1.0.0 du 20-07-17 :
    • Lorsqu'une mise à jour est détectée, un bouton de téléchargement est affiché pour un téléchargement direct depuis le navigateur
    • Les éveils programmés peuvent désormais s'ajuster de façon intelligente en fonction de l'utilisation de chaque machine
    • Collecte pour chaque client du système d'exploitation et de la liste des logiciels installés
    • Possibilité de consigner les événements dans un fichier journal
    • Possibilité de cadencer les éveils distants toutes les 100 millisecondes
    • Amélioration de la procédure de déploiement
    • Amélioration de la méthode de récupération des utilisateurs connectés sur chaque poste client
    • Amélioration de la méthode d'arrêt des clients lors de l'envoi d'une commande depuis le serveur
    • Amélioration de la méthode de transmission des données à Hypnos Manager
    • Hypnos Manager peut transmettre la base de données d' Hypnos Serveur
    • Possibilité de définir le mot de passe SecureOn de l'éveil distant
    • Possibilité de forcer le rafraîchissement de l'état d'un ou plusieurs clients
    • Possibilité d'activer/désactiver en un clic les horaires d'un ou plusieurs profils d'éveil
    • La conservation des données de connexion peut être désormais choisie entre 6 mois et illimitée
    • Réduction de la taille des trames entre Hypnos Client et Hypnos Serveur
    • Correction d'un bug où des clients actifs n'apparaissaient pas allumés dans la console, et où, inversement, des clients éteints apparaissent comme actifs
    • Correction d'un bug de bas niveau pouvant altérer la transmission des données entre les clients et le serveur
    • Correction d'un bug empêchant d'éveiller un client sur le Wan lorsqu'il était pris en charge par un relais actif
    • Correction d'un bug empêchant la prise en compte du mot de passe dans la procédure de déploiement
    • Correction de fuites mémoire mineures

  • Version 3.0.6.8 du 25-01-17 :
    • Réduction des accès disques engendrés par Hypnos Client

  • Version 3.0.6.7 du 20-11-16 :
    • Amélioration de la procédure de validation de licence
    • Meilleure compatibilité avec les systèmes où l'UAC est activée
    • Les mises à jour Windows en attente, s'il y en a, sont désormais installées lors d'un arrêt effectué par Hypnos Client
    • Améliorations ergonomiques de l'arborescence de l'onglet Général
    • Amélioration du calcul des économies qui utilise désormais moins de ressources processeur
    • Amélioration des désinstallateurs d' Hypnos Serveur et Hypnos Client
    • Possibilité de définir un profil Hypnos comme profil par défaut
    • Possibilité de créer un dossier par modèle client et d'y regrouper les clients correspondants
    • Possibilité de sélectionner en un clic tous les clients d'un profils Hypnos , d'un ou plusieurs profil d'éveil , ou tous les profils d'éveil d'un régime de vacances
    • Correction d'un bug empêchant l'exportation / importation des profils Hypnos
    • Correction d'un bug pouvant effacer le nom de l'écran de veille saisi dans un profil Hypnos

  • Version 3.0.6.6 du 27-06-16 :
    • Meilleure présentation des sous-réseaux pour l'éveil des clients
    • Correction d'un bug qui pouvait empêcher l'allumage des stations avant déploiement

  • Version 3.0.6.5 du 05-05-16 :
    • L'installation automatique d'une mise à jour d' Hypnos Serveur se fait désormais lorsqu'elle est publiée depuis au moins 20 jours (au lieu de 10 précédemment)
    • Amélioration de la méthode de recherche des mises à jour

  • Version 3.0.6.4 du 22-04-16 :
    • Les régimes de vacances peuvent être verrouillés sur des zones déterminées
    • Diverses améliorations d'affichage
    • Correction d'un bug de fréquence de recherche des mises à jour

  • Version 3.0.6.2 du 17-04-16 :
    • Possibilité de télécharger et installer automatiquement les mises à jour d' Hypnos Serveur
    • Envoi vers Hypnos Manager de la première et la dernière minutes quotidiennes de fonctionnement de chaque client

  • Version 3.0.6.1 du 11-04-16 :
    • Envoi vers Hypnos Manager des profils Hypnos , d'éveil et des régimes de vacances

  • Version 3.0.6.0 du 02-04-16 :
    • Amélioration de la gestion des paramètres d'alimentation et de l'écran de veille (meilleure compatibilité pour Vista et versions Windows ultérieures)
    • Amélioration du désinstallateur d' Hypnos Client

  • Version 3.0.5.8 du 07-02-16 :
    • Collecte du modèle de chaque poste client
    • Amélioration de la méthode d'envoi des données sur Hypnos Manager
    • Ajout de deux profils d'extinction pré-configurés (salle des profs, poste administratif)

  • Version 3.0.5.6 du 29-12-15 :
    • Correction d'un bug mineur où les ordinateurs allumés durant plus de 24h (serveurs par exemple) n'étaient pas considérés comme actifs

  • Version 3.0.5.5 du 09-12-15 :
    • Redémarrage automatique des services Hypnos Client et Hypnos Serveur en cas de défaillance
    • Correction d'un bug ancien d' Hypnos Client pouvant stopper la connexion au serveur de façon inopinée
    • Correction d'un bug de calcul mineur pouvant survenir dans certains rapports chronologiques
    • Suppression du mode d'obtention des informations de connexion dans l'onglet Configuration : désormais les informations se fient aux données transmises par le client
    • Correction d'un bug d'affichage lors du déploiement où les clients pré-cochés étaient déjà installés

  • Version 3.0.5.0 du 24-11-15 :
    • Refonte d' Hypnos Manager permettant la collecte des données sur un serveur externalisé
    • Chaque station peut désormais avoir sa propre passerelle WOW pour la réveiller
    • Possibilité d'importer les régimes de vacances scolaires des zones A, B, et C
    • Possibilité d'afficher les statistiques générales de nouvelles périodes (7 jours, 30 jours, 12 mois, 5 ans) sur l'écran de bienvenue
    • Possibilité de déclarer un changement de poste pour ne pas perdre les données de connexion d'un client
    • Modification du déploiement automatisé par GPO
    • Améliorations ergonomiques mineures
    • Amélioration de la précision du calcul des économies
    • Correction de la méthode de calcul des adresses MAC
    • Correction d'un bug pouvant afficher des durées négatives dans les relevés chronologiques

  • Version 3.0.4.8 du 17-04-15 :
    • Possibilité d'effectuer un réveil distant (WOL / WOW) par l'intermédiaire d'un client relais ou d'une passerelle Wake on Wan.

  • Version 3.0.4.7 du 13-03-15 :
    • Correction d'un bug pouvant empêcher certaines stations d'être vues dans la console

  • Version 3.0.4.6 du 21-02-15 :
    • Procédure de déploiement plus rapide sur certains systèmes
    • Modification de la méthode de récupération des informations de connexion des clients

  • Version 3.0.4.5 du 31-01-15 :
    • Refonte du système des permissions d'éveil / arrêt
    • Possibilité de saisir un commentaire simultanément pour plusieurs clients
    • Les commentaires et noms des dossiers des clients sont exportés dans les relevés globaux et les exports

  • Version 3.0.4.0 du 01-01-15 :
    • Intégration des profils Hypnos d'exemples Poste professeur et Poste élève
    • Amélioration des relevés chronologiques
    • Les données de connexions peuvent désormais être stockées durant 5 ans (valeur par défaut)
    • Correction d'un bug mineur de calcul de durée des économies dans les relevés chronologiques

  • Version 3.0.3.5 du 20-12-14 :
    • Intégration des régimes de vacances d'exemples des Vacances scolaires zones A, B et C

  • Version 3.0.3.4 du 30-11-14 :
    • Amélioration de la procédure de déploiement
    • Correction de plusieurs fuites de mémoire

  • Version 3.0.3.3 du 08-11-14 :
    • Possibilité d'effectuer un réveil global préalable à un premier déploiement

  • Version 3.0.3.2 du 03-11-14 :
    • Correction d'un bug pouvant empêcher l'éveil distant (WOL) sur le réseau WAN par l'intermédiaire d'un client relais

  • Version 3.0.3.1 du 01-11-14 :
    • Possibilité d'ajouter un commentaire pour chaque client
    • Correction d'un bug empêchant la vérification des mises à jour sur certains systèmes
    • Améliorations mineures d'affichage

  • Version 3.0.3.0 du 28-10-14 :
    • Possibilité de gérer deux modes d'arborescence
    • Possibilité de verrouiller des dossiers pour éviter des actions involontaires sur les clients qu'ils contiennent
    • Possibilité d'effectuer un réveil distant (WOL) sur le réseau WAN par l'intermédiaire d'un client relais
    • Correction de bugs mineurs d'affichage (labels de boutons, scintillements)
    • Correction d'un bug d'affichage dans l'onglet déploiement qui pouvait lister des stations éteintes
    • Amélioration de la transparence des fichiers PNG exportés depuis la page de bienvenue

  • Version 3.0.2.4 du 22-10-14 :
    • Possibilité d'exporter les clients au format CSV ou TXT
    • Correction d'un bug survenant après un import des données de fonctionnement

  • Version 3.0.2.3 du 11-10-14 :
    • Modification mineure du libellé des champs des rapports d'activité
    • Mise à jour du script d'envoi des données pour la compatibilité avec les dernières versions de PHP
    • Ajout de la certification Soft-Micro

  • Version 3.0.2.2 du 23-08-14 :
    • Amélioration du script d'envoi des données

  • Version 3.0.2.1 du 16-06-14 :
    • Correction d'un bug mineur d' Hypnos Client pouvant survenir lors de l'enregistrement de la configuration

  • Version 3.0.2.0 du 31-05-14 :
    • Ajout de la possibilité de plafonner l'estimation des économies réalisées sur une station ayant été arrêtée depuis longtemps par Hypnos Client

  • Version 3.0.1.0 du 25-05-14 :
    • La possibilité d'éveiller / fermer les sessions / redémarrer / mettre en hibernation / arrêter des clients a été étendue aux dossiers
    • Les arrêts des clients effectués manuellement depuis Hypnos Serveur ne sont plus comptabilisés dans le décompte des économies
    • Correction d'un bug d'affichage pouvant stopper la communication avec le service d' Hypnos Serveur

  • Version 3.0.0.0 du 10-05-14 :
    • Passage en version shareware
    • Détection des mises à jour
    • Possibilité de gérer des clients hors du réseau LAN
    • Calculs statistiques des économies réalisées
    • Possibilité de basculer en un clic en mode maintenance pour suspendre les arrêts des ordinateurs
    • Possibilité d'exporter les données de connexion sur un serveur externalisé
    • Possibilité de basculer temporairement l'ensemble des clients en mode maintenance
    • Possibilité de prendre en main en contrôle à distance les stations où Hypnos Client est installé
    • Possibilité de gérer dans les profils Hypnos : le verrouillage de session au-delà d'un délai réglable d'inactivité
    • Possibilité de gérer dans les profils Hypnos : le fonctionnement de l'écran de veille, la mise en veille du moniteur et des disques durs
    • Retrait de la possibilité de choisir pour chaque client la méthode de calcul de son nom NETBIOS
    • Corrections de bugs divers d'affichage et de fonctionnement

  • Version 2.3.6.0 du 16-01-14 :
    • Ajout de la possibilité de choisir pour chaque client la méthode de calcul de son nom NETBIOS
    • Correction d'un bug empêchant dans certains cas l'arrêt des stations en mode veille prolongée
    • Les arrêts des stations effectués par Hypnos (Client ou Serveur) sont désormais pris en compte pour calculer les économies de fonctionnement

  • Version 2.3.4.0 du 31-10-13 :
    • Correction d'un bug pouvant afficher à la fermeture de Windows un message d'erreur d' Hypnos Client

  • Version 2.3.3.0 du 04-05-13 :
    • Ajout de la possibilité de créer des scripts de contrôle pour l'éveil et l'arrêt distant d'un ou plusieurs postes à partir d'un autre
    • Changement de version du composant mORMot pour la gestion SQLite de la base de données
    • Correction d'un bug d'affichage pouvant survenir lors de l'utilisation de la molette de la souris
    • Correction d'un bug pouvant se produire lors de la demande d'arrêt de la procédure de déploiement avant son terme
    • Mise en compatibilité pour Windows 2000

  • Version 2.3.2.2 du 02-03-13 :
    • Ajout de la possibilité de paramétrer les délai de signalement d'activité des clients au serveur
    • Ajout de la possibilité de trier les clients par adresse MAC, IP, numéro de série ou dernière activité
    • Correction d'un problème possible de liaison entre le client et le serveur en cas de connexion lente
    • Amélioration de la synchronisation d'affichage en cas de sessions multiples ouvertes

  • Version 2.3.2.0 du 17-01-13 :
    • Amélioration de la procédure de déploiement (possibilité de ne pas résoudre les IP en noms d'hôte)
    • La liste des groupes de restriction proposée pouvait être tronquée
    • Amélioration de l'installateur
    • Diverses améliorations graphiques

  • Version 2.3.1.0 du 28-12-12 :
    • Amélioration du système d'arrêt des clients

  • Version 2.3.0.0 du 06-10-12 :
    • Mise à jour du système de communication TCP/IP avec les clients
    • Diverses améliorations d'ergonomie

  • Version 2.2.1.0 du 25-06-12 :
    • Le nom des utilisateurs ayant des sessions ouvertes s'affiche au survol de la souris dans la liste des clients connectés
    • Les rapports chronologiques d'activité des clients indiquent le nom des utilisateurs et la version du serveur Hypnos
    • Correction d'un bug mineur pouvant empêcher durant quelques minutes l'envoi de commandes à un client ayant changé d'IP
    • Correction d'un bug pouvant survenir lors de l'importation d'une configuration

  • Version 2.2.0.0 du 21-04-12 :
    • Refonte du système de communication TCP/IP avec les clients
    • Le client peut désormais être installé / désinstallé par simple ligne de commande (possibilité de mettre en place un déploiement automatisé du client via GPO)
    • Correction d'un bug mineur dans la procédure de déploiement à distance (le client ne s'installait pas toujours directement)
    • Diverses améliorations mineures de l'application serveur

  • Version 2.1.7.0 du 01-04-12 :
    • Amélioration de l'ergonomie
    • Correction d'un bug sur le client

  • Version 2.1.6.0 du 24-03-12 :
    • Retrait du mot de passe serveur
    • Amélioration du rafraîchissement de la liste des clients connectés

  • Version 2.1.5.0 du 11-03-12 :
    • Prise en charge du numéro de série des postes clients
    • Correction d'un bug empêchant la saisie correcte des horaires d'éveil

  • Version 2.1.0.0 du 08-02-12 :
    • Possibilité de générer des rapports d'activité d'un ou plusieurs clients

  • Version 2.0.8.0 du 01-02-12 :
    • Correction bug : sur certaines architectures de domaines, le serveur ne pouvait pas s'installer

  • Version 2.0.7.0 du 23-01-12 :
    • Correction bug : le signal Wake-On-Lan n'était pas toujours acheminé
    • Correction d'un bug lors de l'envoi d'une commande manuelle pouvant fermer les sessions, redémarrer, mettre en hibernation ou arrêter un ordinateur non sélectionné
    • Correction bug mineur d'affichage

  • Version 2.0.6.0 du 14-01-12 :
    • Correction bug : les clients arrêtés subitement n'étaient pas pris en compte par le serveur et restaient allumés
    • Possibilité de prise en charge d'un fichier de logs en créant manuellement un fichier nommé HypnosServeur.log dans le répertoire d'installation du serveur qui le renseignera automatiquement
    • Mise en compatibilité avec le client : Amélioration de la procédure d'arrêt depuis le serveur

  • Version 2.0.5.0 du 10-01-12 :
    • Mise en compatibilité avec le client : Correction d'un problème pouvant survenir si le service Terminal Serveur n'est pas actif

  • Version 2.0.4.0 du 07-01-12 :
    • Mise en compatibilité avec le client : Modification de la méthode d'extinction ; certaines stations ne s'éteignaient pas correctement

  • Version 2.0.3.0 du 06-01-12 :
    • Mise en compatibilité avec le client : Possibilité de surveiller en permanence l'inactivité si aucune session n'est ouverte

  • Version 2.0.2.0 du 04-01-12 :
    • Mise en compatibilité avec le client : Détection des sessions actives
    • Sélection par défaut des stations sans client pour le déploiement

  • Version 2.0.1.0 du 01-01-12 :
    • Mise en compatibilité avec le client : Prise en compte des applications fonctionnant en plein écran pour retarder la fermeture
    • Fichier d'aide

  • Version 2.0.0.0 du 25-12-11 :
    • Première version stable


Liens

Site Web d'Hypnos : https://hypnos.soft-micro.fr

Téléchargements :

  • Hypnos Client : https://hypnos.soft-micro.fr/HypnosSetup.exe
  • Hypnos Serveur : https://hypnos.soft-micro.fr/HypnosServeurSetup.exe
  • Hypnos Manager : https://hypnos.soft-micro.fr/HypnosManager.zip

Auteur : Sébastien Bégouin - contact@soft-micro.fr